Handoff option missing in System Preferences — MacBook Air (Mid 2011) + iPhone 6

glenayre

macrumors newbie
Original poster
Oct 17, 2014
3
0
New South Wales
When I go into System Preferences->General, there is no option to select "allow handoff".

I have been using all of the Yosemite public betas, and I even downloaded the official release today and installed that. Still no luck. Phone calls work to my macbook air, but I can't get any icons to show up on the left hand side of my dock on the air, nor can I get any icons to show up on the lock screen on my iPhone.

I have checked all the steps. I have signed out of and back into iCloud on both my Macbook Air and my iPhone 6. I have bluetooth and wifi turned on and connected to the same network on both devices. The bluetooth on my Air is supposed to be compatible (0x6), according to other forums I've read.

Help?:confused:
 

airlied

macrumors 6502
Jul 8, 2011
381
54
This is what I posted somewhere else, it might help you.

Make sure your devices (ios and Mac) are on the apple support lists.

Then login the same iCloud account using the SAME email address (different email under the same iCloud account won't work), go to messages and FaceTime on iPhone, turn on "SMS Relay" and "use iphone to make calls" in each setting.

Then go to your Mac, open FaceTime settings and make sure "iphone cellular calls" are checked.

Then go back to your phone, go to general-handoff, turn on everything.

Then open contact on your Mac, call somebody to see if it works.
 

glenayre

macrumors newbie
Original poster
Oct 17, 2014
3
0
New South Wales
Thank you, the phone calls work fine, it's the handoff of other apps (Pages, Safari, Keynote, etc) that I would like to get working.
 

hounslowfish

macrumors regular
Oct 2, 2013
111
30
The Mid 2011 MBA is not officially supported for Continuity even though the hardware would allow it. You need to apply the hack detailed in other threads. (Didn't work for me - worked for others).