iPhone Haptics inconsistent after updating to 13

mebehere

macrumors 6502
Original poster
Sep 21, 2012
436
221
My XR is experiencing haptic issues that I don’t recall while on 12.4.1.

The intensity of the taps is all over the map. Sometimes they’re strong. Sometimes they’re weak and sometimes there’s no tap at all.

A test I do is to long press the flashlight in the control center over and over. It’ll be very strong and then very weak for several taps and vice versa.

It’s happening system-wide though. Often when I swipe up to activate the app switcher, there’s no haptic feedback at all.

Anyone else having similar issues?

Thanks.
 
Last edited:

mebehere

macrumors 6502
Original poster
Sep 21, 2012
436
221
I'm having the same issue with my XR. Has anyone found any fix for this?
Couple questions...
How long have you had your phone?

Did it start after installing iOS 13? I think my problems did but I’m not sure.

I’ve tried many things, but I haven’t set up as new yet.
 

brandonboo20

macrumors newbie
Apr 10, 2012
20
10
Noblesville, IN
Couple questions...
How long have you had your phone?

Did it start after installing iOS 13? I think my problems did but I’m not sure.

I’ve tried many things, but I haven’t set up as new yet.
I've had it 3 months now. Problems didn't start until after updating to iOS 13. I've done every update so far and still had the same issues. No other problems with mine. I've done everything short of setting up as new as well.
 

mebehere

macrumors 6502
Original poster
Sep 21, 2012
436
221
I've had it 3 months now. Problems didn't start until after updating to iOS 13. I've done every update so far and still had the same issues. No other problems with mine. I've done everything short of setting up as new as well.
I erased all content and settings and restored from an iCloud backup earlier. Still not working right.

I wonder why more people aren’t having this issue.
 

utente__mac

macrumors newbie
Sep 20, 2015
18
8
I have the same issue on my iPhone XS since probably 13.1. I don’t recall having the same with 13.0.

When I unlock my iPhone there’s no haptic feedback at all.
In le unlocked the haptic feedback seems to work just fine.

On iOS 12 it never ever missed an haptic feedback while using the swipe gesture from the bottom of the screen.
 

mebehere

macrumors 6502
Original poster
Sep 21, 2012
436
221
I have the same issue on my iPhone XS since probably 13.1. I don’t recall having the same with 13.0.

When I unlock my iPhone there’s no haptic feedback at all.
In le unlocked the haptic feedback seems to work just fine.

On iOS 12 it never ever missed an haptic feedback while using the swipe gesture from the bottom of the screen.
I don’t think I’ve ever had haptic feedback when swiping up from the lock screen. Are you saying you have no issues other than that?
 

mebehere

macrumors 6502
Original poster
Sep 21, 2012
436
221
I've had it 3 months now. Problems didn't start until after updating to iOS 13. I've done every update so far and still had the same issues. No other problems with mine. I've done everything short of setting up as new as well.
I’ve noticed something. When swiping up to activate the app switcher and the haptics aren’t working, I can simply lock the phone, wake it back up and they work again, at least for awhile.

You could try this and reply here to let me know if your phone does the same thing.