Hard Drive issues w/ Panther

Discussion in 'Macintosh Computers' started by Bob K, Jan 8, 2004.

  1. Bob K macrumors newbie

    Jan 8, 2004
    I have a b/w g3 300 w/ Panther installed - there are two Drives, the original 6Gig HD and a second Western Digital 40Gig drive.

    When I startup, the 2nd drive is not recognized (it was in Jaquar) and I get a "do you want to initialize" message.

    Disk Utility "sees" the drive, but will not allow me to mount it or repair it (Invalid file or directory ID found, Volume Check Failed)

    The three partitions are listed, greyed out, as Disk1s9, Disk1s10 and Disk1s11

    Norton sees the drive (as untitled 1, 2 and 3) and tries to repair it but it crashes Norton before it finishes.

    Disk Warrior (the lite version that comes w/ Norton Systemworks) Sees the drive and can get some of the data, but buy no means all of it, some of which hadn't been backed up (of course) and is (of course) very important to me.

    I've exhausted my Mac Geekiness - anyone help?
  2. mico macrumors newbie

    Jul 2, 2003
    Two suggestions. If you can boot in os9 see if the drive is recognized there. If it is then I would suggest getting an external drive and backing up on that but format it with panther disk utility first. If not get the full version of Disk warrior and see if it can help the recogntion problem. And lose norton.
  3. Bob K thread starter macrumors newbie

    Jan 8, 2004
    Yeah, OS9 doesn't mount it either. Disk First Aid sees it, but can't repair it.

    I guess i'll fork over the cash for the full version of DW
  4. Calliander macrumors member

    Jan 7, 2004
    Long Beach, CA
    Have you tried Norton for X and 9? Sometimes, Disk Doctor can fix stuff in 9 that it cannot in X and you have the luxury of being able to boot 9 with the Blue & White.

    The full DiskWarrior will probably help. There's also TechTool 4, Data Rescue X, and Drive 10.

    Good luck!

    EDIT: Also, have you tried fsck?
  5. Bob K thread starter macrumors newbie

    Jan 8, 2004
    I'll give it a shot in 9 and see

    I haven't tried fsck - but I could...but what is it? lol
  6. tomf87 macrumors 65816


    Sep 10, 2003
    fsck is short for filesystem check. It checks and fixes filesystem errors.

    From single user mode (hold down Command-S while powering on), run 'fsck -y' and it will check it.
  7. Bob K thread starter macrumors newbie

    Jan 8, 2004
    ok, I ran fsck on the startup disk and it was ok, but how do i run it on the second disk? Using what little common sense I could muster, i tried typing dev/disk1s9 which may or may not have been a smart thing to do...but either way, it said permssion denied.
  8. Bob K thread starter macrumors newbie

    Jan 8, 2004

Share This Page