Hard drive space disappeared after Ubuntu installation…

Discussion in 'macOS' started by rainbowwarrior1, May 2, 2011.

  1. rainbowwarrior1 macrumors newbie

    Joined:
    May 2, 2011
    #1
    I've just lost ~40GB of space on my hard drive, after installing Ubuntu on a new partition. Hopefully someone can help me figure out why.

    I started off with three partitions on my 250GB drive — 210 for Snow Leopard, 25 for Windows, 15 for Lion (going by SL's base-10 numbers).

    The SL one had around 160GB used (i.e. 50GB free), then I shrunk it by 10GB to install Ubuntu which was all fine.

    After restarting the computer into SL I got the 'startup disk full' error message at the login screen. It wouldn't let me login to either my account or the guest account, showing only a blank screen. Lion, Ubuntu and Windows all worked as usual and had not been affected.

    I deleted the Ubuntu partition and gave the 10GB back to SL, which allowed me to login normally. However, I only had that 10GB of free space, with the other 40GB still missing.

    I've gone through Finder trying to work out where the space has gone, but with no luck. DaisyDisk and WhatSize don't show anything either. Attached is a screenshot of WhatSize's results (smaller folders excluded) — clearly only 160GB is used, but a total of 200GB is reported.

    If anyone can help work out what's going on, I'd really appreciate it. If nothing can be done, I'll just reinstall SL and copy everything back across bit-by-bit.


    tl;dr — I had 50GB free space, restarted computer and had 10GB free… PLZ HALP!
     

    Attached Files:

  2. rainbowwarrior1, May 4, 2011
    Last edited: May 4, 2011

    rainbowwarrior1 thread starter macrumors newbie

    Joined:
    May 2, 2011
    #2
    I hate to bump, but has no-one come across this before?

    For what it's worth, rEFIt still shows an icon for the Ubuntu partition, even though there's no sign of it in either of rEFIt's own partition tool or Mac's Disk Utility.

    I have also just finished a SuperDuper backup of my Snow Leopard partition, which is only the size it 'should' be (i.e. 160GB). I assume this must mean it's a disk error of some sort, as opposed to a hidden file getting stuck somewhere?

    Obviously I can now just reformat and restore from that backup, but I'd rather not go through the hassle if anyone knows a way of 'force-verifying' the HD usage if such a thing exists? I've tried permissions and disk repair, but neither worked…

    Again, any help would be fantastic and I'd be hugely grateful.
     

Share This Page