Having a problem with Call of Duty

Discussion in 'Games' started by Perfusion, May 8, 2006.

  1. Perfusion macrumors newbie

    May 8, 2006
    San Jose, CA
    Purchased Call of Duty today for my Intel-based iMac. The game runs like a dream, up until the end of the 3rd or 4th level/mission. As it's loading the next mission, I get an error message that reads,

    "Error: Max number of disconnected paths exceeded"

    And I can't go any further...basically just back to the main menu. So....I do some searching, and find a patch (1.5c). I download it and install it. When I click on the CoD icon to start the game, it asks me for the CD. I put it (a DVD, actually) in the drive and click, "Continue," but it doesn't do anything...just prompts me with the same statement.

    I've tried reinstalling it, and without the patch I get the same Error message. With the patch installed, I get the same window that pops up asking me for the CD...frustrating.

    Does this sound like a problem anyone has encountered before?

    Thanks so much...

  2. pknz macrumors 68020


    Mar 22, 2005
    Have to ask is it a legally bought (original) DVD?

    Did you update COD with COD: United Offensive update?
  3. Perfusion thread starter macrumors newbie

    May 8, 2006
    San Jose, CA
    Yes...purchased at the Apple Store today. I wasn't aware UO was an update...thought it was more of an "Expansion Pack." Should I?
  4. Perfusion thread starter macrumors newbie

    May 8, 2006
    San Jose, CA
    Problem solved! I called Aspyr this morning and spoke with a Tech Support guy who has very helpful. He said that the error which I was encountering was basically just a carry-over from the PC version of the game, and it was never caught. (Although I don't know how, as it happens pretty early in the game) At any rate, the only way to get past the error is to use "console commands" to manually trigger the next map. Yes, you will miss out on the 1 map that has the error, but it's better than not being able to play the rest of the game.

    First, ensure Console is enabled (it's a checkbox in one of the sub-menus under "Options"). Once console is enabled, hit the "~" key to bring up the console. The map that has the error is called "Dawnville", so you will want to manually skip to the next one - "Car Ride."

    In the console, type "map carride" (except without the quotation marks) and that should take you to the next level! Additionally, here are all the levels in the game (by map name)

    Car Ride
    POW Camp
    Pegasus Night
    Pegasus Day
    Truck Ride
    Red Square
    Train Station
    Rail Yard
    Tank Drive Country
    Tand Drive Town

    Hope this helps anyone who, in the future, might experience the same problem as I! For a list of all other console commands (i.e., cheats), and what they do, just Google "Call of Duty Console Commands."

    Best of luck,

  5. Squozen macrumors member

    Oct 9, 2003
    Thanks for the list. The game works fine on my PowerBook but fails the same way you've seen on my Intel iMac. Hopefully they'll have a chance to look at the problem when they release a universal binary patch.
  6. pedruino macrumors newbie

    Aug 17, 2006
    Buenos Aires, Argentina
    Hello, I am Pedro and I have same problem that you had. I have been trying to follow your steps but I couldn´t bring up the console. I manage to enable the Console but once I do that I didn´t know which was the "~" key (that enables to bring up the console). Please, if you can help me with this problem I will be very thankful.
    PD: Sorry for my english (I am fron Spain):)
  7. sundevil67 macrumors newbie

    Dec 15, 2005
    Can't Bring up Console

    I am having the same problem with Call of Duty. I found the fix, but I can't seem to invoke the console. I press the ~ key, but nothing happens. I am using a Windows-style keyboard with my MacBook Pro however; I wonder if that has something to do with it. Though the tilde key is clearly the tilde key - anyone have any advice? This is really frustrating.


  8. dilbertyes macrumors newbie

    Feb 13, 2007
    my solution

    Try with the key with this to signs <>.
  9. sundevil67 macrumors newbie

    Dec 15, 2005

    No dice - I can't seem to bring up the console no matter what key I press. Is there another way? I just am never going to be able to call support during business hours unfortunately, unless I take the morning off of work!

Share This Page