iPhone Having an impossible time restoring JB iPhone4 on 5.0.1 to 5.1.1, baseband 1.59

Discussion in 'Jailbreaks and iOS Hacks' started by LAjyo, Sep 25, 2012.

  1. LAjyo macrumors newbie

    Joined:
    Sep 25, 2012
    #1
    Now that my phone has been unlocked by AT&T, I need to restore it via iTunes to complete the unlock. My phone is on baseband 1.59 and OS 5.0.1 so at this point, there is no reason to not update it and update the baseband (assuming this is ok).

    However, iTunes will not let me restore it. I have saved SHSH blobs if TinyUmbrella and Cydia are to be believed as it seems to have saved everything including a blob for 5.1.1 and 5.1.1r1.

    iTunes throws an error of type 11. I even checked, and doublechecked the .hosts file. I even tried iTunes 10.6.3 and 10.7, Mac and PC but to no avail.

    I tried updating to a pure 5.1.1 GSM ipsw and a custom one generated using RedSn0w. Nada.

    Anyone have any pointers. My phone is finally unlocked and I can't restore it so when it activates, it unlocks it.

    Thanks!
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    I recommend doing this:
    To apply the IMEI unlock, you do not need to restore. Get SAM from Cydia (http://www.bingner.com/SAM.htm) and run it, Utility tab select deactivate the phone. Kill SAM in task manager.

    Plug the phone into iTunes to reactivate - YOU MUST have a sim in it to re-activate. The unlock will attach.

    Once you see the unlock window and you verify the phone is indeed unlocked, then is the time to upgrade the firmware and baseband.

    In order to restore to 5.1.1 you must stitch the hash and APTicket files to the IPSW. iClarified.com has a tutorial. Use Redsn0w to put the phone in pwnedDFU mode and apply the IPSW
     

Share This Page