hd5870 on mac pro 2008 – no mdp

Discussion in 'Mac Pro' started by avvvid, Nov 17, 2010.

  1. avvvid macrumors newbie

    Joined:
    Nov 17, 2010
    #1
    hello everyone,

    I received my hd5870 today and so far, it is working like a charm (very quiet compared to my previous card). however there’s one thing I noticed: I’ve connected one 23" ACD via DVI and one 23" ACD via Minidisplay-to-DVI-Adapter (the small one, not the active dual-link one).

    The display connected to the MDP via adapter doesn’t work. Neither does OSX recognize the monitor nor does the monitor recognize to be connected.

    Could this be related to the adapter? Do I need a dual-link adapter?
     
  2. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
    #2
    You even said it yourself. MDP on the 5870 needs an active adapter - doesn't have to be dual-link, but needs to be active.
     
  3. Transporteur macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #3

    AFAIK, this applies only if you want to run three DVI displays from a single card. For dual screen setups the standard miniDP to DVI should work just fine.
     
  4. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
    #4
    Doesn't work for me. My MDP ports just refuse to output to DVI using Apple's adapter.

    [EDIT: I take that back. According to Apple it should work... http://support.apple.com/kb/HT4279
    It appears you have to specifically use the MDP port furthest away from the DVI port, and leave the middle empty]
     
  5. Transporteur macrumors 68030

    Joined:
    Nov 30, 2008
    Location:
    UK
    #5
    That's odd. The Apple support forums are packed with topics like these and basically all of them say that you need such adapters only for triple screen setup.
     
  6. avvvid thread starter macrumors newbie

    Joined:
    Nov 17, 2010
    #6
    It’s working now. Leaving the middle port empty and making sure the MD-Plug is connected properly did the trick for me.

    So 2 Displays using the DVI-Port and one MDP via passive Adapter works. Thanks, guys!
     
  7. jjsanderson macrumors newbie

    Joined:
    Jul 5, 2010
    #7
    Another data point

    OK, that's weird.

    My 5870 arrived yesterday, and apart from it (a.) being just a hair quicker than the 2600 it replaced (*ahem*), and (b.) being quieter than aforementioned 2600, it's quite happily driving two DVI screens.

    The first, hooked to the DVI port, is a 23" ACD. The second is a modest 22" Samsung (1680x1050) display, hooked via a standard miniDP-DVI adaptor, to the... middle miniDP socket.

    Of course, as soon as I post this message noting that it works, it'll stop working. You watch. Logic, t'ch!
     

Share This Page