Headphones plugged in sound from speakers work, headphones unplugged spkrs dnt work

Discussion in 'MacBook Pro' started by andrewtheboss, Feb 16, 2008.

  1. andrewtheboss macrumors newbie

    Joined:
    Feb 16, 2008
    #1
    I have a Macbook Pro from 06 of december and i use it for leisure and recording music. I recently plugged in headphones to my mac and everything went haywire. The internal speakers didnt work unless i plugged in the headphones. Ive taken it to the mac store and the guy suggested that the sound card has been damaged or i might need a new output. i would like a second opinion. i know the speakers work its just when i plug in the headphones the speakers work and if i unplug the headphones the internal speakers dont work. The internal speakers do not show up on the sound preferences . What do i do? I have read threads about moving a toothpick or etc in the speaker i/o and the red light shows up and goes away WHAT DO I DO! please respond soon because im running out of time!:(:apple:
     
  2. superleccy macrumors 6502a

    superleccy

    Joined:
    Oct 31, 2004
    Location:
    That there big London
    #2
    Do the internal speakers show up in the system preferences when your headphones are plugged in?
     
  3. andrewtheboss thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #3
    well now when i plug in the headphones the speakers do not show up. When i reboot my mac the sound it makes when it reboots is audible but after that it doesnt work
     
  4. Digital Skunk macrumors 604

    Digital Skunk

    Joined:
    Dec 23, 2006
    Location:
    In my imagination
    #4
    I along with many other MBP owners have this problem. It's something to do with the mobo and Apple will fix it if it's under warranty. I don't know how much it costs if out of warranty but I think all Apple does is replace the audio port and you should be up and running.

    Do you get a red light coming from the inside of the audio port? If so then it's the documented problem I speak of. If not, then I am sorry, I don't know what that is all about.
     
  5. odagled macrumors member

    Joined:
    Aug 10, 2007
    #5
    so do you have the red light showing up in the jack? Happened to me, persistence is the key.
     
  6. andrewtheboss thread starter macrumors newbie

    Joined:
    Feb 16, 2008
    #6
    I don't get the red light. I took it to the mac store and they said they need to replace the audio port, but the guy was being a dick and i wasn't sure if he was telling me the truth or just b.s-ing me.
     
  7. superleccy macrumors 6502a

    superleccy

    Joined:
    Oct 31, 2004
    Location:
    That there big London
    #7
    Whatever the problem, it certainly sounds like a hardware fault. Let them fix it.

    SL
     
  8. go.mouse macrumors newbie

    Joined:
    Aug 10, 2007
    Location:
    Vancouver, BC
    #8
    I just started experiencing exactly the same problem on my 2.4GHz 17" MBP. When headphones are not plugged in, it shows Digital Out (Type: Built-in Output) and the selected device has no output controls.

    This is weird.
     

Share This Page