Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Health App reset and lost all my settings


macrumors 68000
Original poster
Dec 23, 2010
London, UK
Hi guys,

I've set up my Dashboard on the Health app to show mu steps, walking distance, heart rate and sleep. All has been good for the past 1.5 weeks, until now - my Dashboard has been reset including my personal information such as birthdate, gender etc! However, it seems the data such as steps etc has not.

Kind of peeved off that I have to set it all up again. How does Apple expect users to rely on and trust their data to be secure? So far it's been a flop and totally unreliable. Kinda ironic since I just saw their advert on the TV showing off the Health app a few minutes ago.

Anyone else had this issue? :(



macrumors 6502
Dec 6, 2012
Have you tried turning it off and on again?

(it being the phone, not the app... read a couple of times that will repopulate the graphs)


macrumors 65816
Mar 17, 2009
Wash, DC Metro
Same here. Everything is gone today.

I have tried all the recommended fixes that I have found on both this site and other sites via a Google search.

Hoping things will just appear in the same manner that they disappeared.


macrumors 68030
Oct 14, 2011
Happened to me 2 or 3 times now. Reboots fix it, or, for some odd reason, it fixes itself in time.


macrumors newbie
Aug 15, 2010
Glad to see that I am not the only one experiencing this issue. This app is really buggy. When I open the app to view my step count its a crapshoot if the dashboard will be like I left it or completely blank like the OP showed.


macrumors regular
Oct 12, 2014
I did a clean install of iOS 8.0.2 on my 5s yesterday. Every data in Health App is gone... a reboot did not fix anything. Would be nice if you could backup the Health data in iCloud, but that is not possible yet, or?


Feb 17, 2003
New Jersey USA
I had this problem first appear last week. Did the hard reboot, did the Apple suggested open Health, go to Fitness then steps, then walk for a minute, hard reboot and hope.

Still no luck.

Now I updated to 8.1 hoping it would be fixed.

Nothing. Dashboard shows up at least but with no data.

Disappointing- no idea what to do now.

I know I could try a full restore.

I have two issues with this.

1. It will loose some progress and settings. No matter what Apple says this process always looses log ins, passwords, some app settings and progress, etc. It is not truly a backup and restore.

2. It is a huge inconvenience for a crap shoot that may not even work.

Of course I may have no choice. But I am hoping word of a patch or some other creative person will find a cause and solution for the problem.


macrumors newbie
Sep 14, 2014
Everything was wiped a few days ago but seems to have re-appeared as mysteriously as it disappeared.

One of the many irritating bugs in iOS 8....

Apple's quality control issues really need to be addressed.

We've gone from 'it just works' to 'it just about works - sometimes'
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.