Helè - iMac 21,5 with snow leopard won't connect to home (unprotected!) WIFI network

Discussion in 'iMac' started by renzopanta, Mar 24, 2010.

  1. renzopanta macrumors newbie

    Joined:
    Mar 24, 2010
    #1
    Hi all,
    Yesterday I got my new iMac 21,5'.

    After starting it up, the airport would not work.

    The open network (not password protected) was detected, but every attempt to connect to it ended with a "timed out" error message.

    I tried to deactivate and reactivate the airport a few times. With no luck.

    Both my iphone and a cheap netbook would get a valid connection in the meantime. So it's not a network issue.

    It's a d-link router and it's about half a meter from the imac.

    My previous macbook with tiger worked perfectly with this connection.

    I tried to change the wireless channel from 7 to 6 and this did not solve the issue. Or at least not right away.

    I tried again after say 15 minutes, and it worked...

    However, tried again in the morning, and got the "timed out" error message one more time...

    Any suggestions?

    PS I have installed the airport software update
     
  2. rpang macrumors member

    Joined:
    Apr 20, 2009
    Location:
    So Cal...
    #2
    Try releasing all of the ip addresses on your router. Your router might not be giving your iMac an IP address because for some strange reason, its all used up.
     

Share This Page