Help! Can't reinstall 3.1.3 --> 3.1.3 and phone is dead

Discussion in 'Jailbreaks and iOS Hacks' started by hiltxan, Dec 6, 2010.

  1. hiltxan macrumors newbie

    Joined:
    Dec 6, 2010
    #1
    Hi all,

    I have a 3GS (not sure of the bootrom) and never before jailbroken. I was going to update to 4.1 today, but before I did, I tried to jailbreak it to save the SHSH on cydia and now it's turned into a paperweight.

    I'm not sure what I can do right now - I want to either keep it as 3.1.3 or update to 4.1 but I don't want to update to 4.2.1

    My problems are:
    - I can't get 3.1.3 to reinstall. I'm not technically downgrading, but I just want to install the current version on it. I tried using a lower version of itunes, but I still end up getting 1600, 1604 errors. Then I tried iReb to no success.
    - I would upgrade to 4.1, but I think iTunes doesn't sign off on it anymore. Argh..it was just working a few days ago when I jailbroke it for a friend.

    Now what are my options?

    Thanks!
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    Without saved old SHSH files, you can't restore to anything other than 4.2.1. That would be your only option.

    And, regarding saving SHSH files, your phone does not have to be JB to do it. You can use a program called Tinyumbrella. Also, what SHSH firmware files you can save has nothing to do with what current firmware is on the phone, by only what Apple is sending out, currently only 4.2.1.
     
  3. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #3
    Yeh you can't even reinstall now to a firmware like that unless you have all the blobs and that. Why don't you want 4.* ?
     
  4. hiltxan thread starter macrumors newbie

    Joined:
    Dec 6, 2010
    #4
    I entered the ECID manually and then it found SHSH's for 4.2.1 and 4.2b3. Why is that? I never installed these firmware versions on it and the most current version that was running was 3.1.3

    Am I out of luck now?

    I'm fine with 4.1 but not 4.2 because I can't unlock it and the jailbreak for it is kind of still working out the bugs.
     
  5. Zermelo macrumors regular

    Joined:
    Nov 18, 2010
    #5
    I'm really curious, how did you mess up this jailbreak?? what did you use.

    If you were on 3.1.3, then all you had to do is go to jailbreakme.com and slide the bar. It's the easiest jailbreak in the world.
     
  6. hiltxan thread starter macrumors newbie

    Joined:
    Dec 6, 2010
    #6
    I used limera1n to jailbreak it and it didn't work. It froze on the apple screen.

    I know that there were other options available, blackra1n, spirit and jailbreakme.com but I just picked the most recent one and thought it would work.

    Turns out, it froze my iphone
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Yep, your SOL.
    With the only SHSH's you have now is 4.2.1 its all you can restore to.
    You should have started backing up your shsh's way earlier with tinyumbrella.
     
  8. Zermelo macrumors regular

    Joined:
    Nov 18, 2010
    #8
    Hmmm, well tough lesson learned. You should have done everything in the world possible before restoring it since you didn't have any saved shsh blobs. Now you're stuck on unthethered jailbreak and unlockable.

    Well since this is the first time you are jailbreaking, then you are on the default carrier, so no harm there, so it's just the tethered jailbreak. No damage really done.
     
  9. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #9
    Repeat again:
    And, 4.1 or 4.2 doesn't matter. Both baseband can't be unlock unless you go installing iPad baseband route.
     
  10. iOS4.1 macrumors newbie

    Joined:
    Jan 10, 2011
    #10
    Hi Hiltxan,

    I see your problem, but all may not be lost, I think you find that using iOS3.1.3 will be impossible now for you as you haven't any saved SHSH Blobs, however I like you dislike 4.2.1 due to it having features that where available in 4.1 not working now :(. I got my iPod Touch 3rd Generation in September and has used 4.0.2, 4.1 and 4.2.1. I got very excited about 4.2.1 and couldn't wait for it to come out but when I used it I couldn't get on with it so I downgraded, however I didn't save any SHSH Blobs for the device. However there may be still a way around for you that has worked for me many times, I managed to downgrade from 4.2.1 to 4.1 without SHSH Blobs, this was just by downloading the ISPW for 4.1 and holding down shift and clicking restore and locating the ISPW it surprisingly went through and restored after this I made sure I saved the SHSH Blobs for it, I think the reason why it was able to do downgrade was due to the fact that 4.1 has not been unsigned by Apple yet so if I was you I would do this ASAP as it may not be signed for long.

    Also wonder if anyone can help me but I no longer have the iPod Touch that I was just talking about above as it had a duff battery so Apple replaced it with the same model. I am running 3.1.3 and was going to upgrade to 4.1 but was told not to by a Jailbreak obsessed friend, as I would not be able to get it back EVER AGAIN but will I be missing out if I upgrade to 4.1 as to me 3.1.3 is not that very good.
    Cheers
     

Share This Page