Help-Dead Slot-Loading iMac!

Discussion in 'Macintosh Computers' started by Balin64, Jun 23, 2004.

  1. Balin64 macrumors 6502a


    Jul 23, 2002
    In a Mauve Dream

    Today I got a slot loading G3 400 iMac from a friend. I was told it has all updates, but when I went to install OS 10.3 I got an alert saying the firmware had to be updated. The only option I was given was to click on a button that said "close" so I did. After that, the screen went blue and I got the spinning clock-type icon for a looong time. Then the screen went black. I assumed it was supposed to boot back into 9.1, which was installed on it.

    Everything I have tried failed. When I push the power button, I get a chime and then about ten seconds later I hear the machine power down, but not all the way... there's a faint clicking sound.

    I tried everything: holding the mouse down at start up to remove the Panther CD did not work, so I had to manually remove it from the iMac using that very weird "magic hole" which is not manual but electronic.

    I then attempted to reset PRAM but only got to the second chime before it died again.

    I then tried to reset evrything by booting into open firmware, but I could not even taht worked.

    Is this Mac dead? I suspect somehow the firmware is corrupted. But HTF did this happen?

    Now, I have to actally unplug the power, wait a few seconds ann then hit the power button again.

    If I hold down the power button, the power light will go off and the Mac will be silent, but if I press it gain, the power light comes on but NOTHING happens! I actually have to pull the power cord, wait, re-plug it and then I get a chime, but like I said earlier, things spin and wirr for about ten seconds, then silence.

    Any ideas? I don't think my friend handed me a lemon this afternoon. I want to fix this thing! Do you think that finding the logic board battery and removing it is going to solve the issue?

  2. andrewm macrumors regular

    Apr 2, 2004
    Los Angeles, CA
    Firmware updates

    If I recall correctly, with firmware updates you need to hold in the programmer's interrupt button (one of the two tiny labelled holes in the same general area as the other ports on the side of the machine) with a paperclip whilst you push the power button, until your computer gives a long chime.

  3. Finiksa macrumors 6502a


    Feb 23, 2003
    Your iMac may or may not be dead, this is a common problem with upgrading to Jag/Panther on G3 iMacs without updating the Firmware before.

    It looks like you may have caused more problems by resetting the PRAM, but hopefully the iMac is still salvageable.

    Try following this troubleshooting guide here.
  4. Spock macrumors 68000


    Jan 6, 2002
    Do You know how to reset the PMU?

    Dissconnect the power cord and check the battery it should read 3.3 to 3.7 volts if not replace it. After checking Press the PMU reset switch on the logicboard DO NOT PUSH A SECOND TIME. Then wait ten minutes and connect the power cord and power up the computer .
  5. musicpyrite macrumors 68000


    Jan 6, 2004
    Cape Cod
    Yea, this could be a very serous problem, one that happens once in a while. And I'm very supprised and dissapointed in Apple for not putting in some kind of safe-guard.

    You might have to end up just scrapping the computer. Or just buying a new hard drive. Or there might be just a simple fix. Call and Apple store and see what they say. After all, Apple did build that computer.
  6. Spock macrumors 68000


    Jan 6, 2002
    I do not think a new Hard Drive will fix the Firmware
  7. poohagen macrumors newbie

    Jul 12, 2004

    I have a very similar program. Iv'e been searching the net all day to find out how to fix it. My imac isn't the slot loading. It's the tray loading.

    I suspect it's the battery but i have no idea where that is. If someone could give me instructions on how to locate it i would be so happy.

    The sad thing is that i don't need the computer; i only need one spreadsheet file that's on it. Isn't that just a kick in the ass?
  8. emc2 macrumors newbie


    Jul 12, 2004
    Either Seattle or Kona...
    Try DiskWarrior 3.0 It is a really great utility for all sorts of problem solving.
    That being said, I hate it when people try to tell me to buy something to fix my problems...

    I had a similar issue with a G3 400 imac when I bumped it to Jag. Try going back to the oldest install disk you have...preferably the install that came with the machine, then bump it up ONE OS/UPDATE AT A TIME to where you want it. After all installs run Disk Utility. I think that it also helps to run OS 9 updates from Apple web site before bumping to OX X.
    I thought mine ws gone at one time to, but it has worked like a charm for the last eleven months since I did the "OS Climb".
    If that fails I really do recomend DiskWarrior.

Share This Page