Help - F1 through F12 all need *fn* key to work... wtf is goin on

Discussion in 'MacBook Pro' started by Koobs123, Feb 26, 2013.

  1. Koobs123 macrumors member

    Joined:
    Jul 29, 2008
    #1
    LAZY ALERT:just skip to the last paragraph, orrrr for the really lazy just read the bold section orrrrrrrr better yet if U can only read a few words before it hurts just read the red coloured words

    Okay well this macbook pro retina i got less than a month ago so its fairly fresh. I had done two things to mess with any sort of system settings which i explain in points one and two...

    1. I had installed crystal clear which is a themeing (is that a word?) program and although it was a little sketchy I decided to give it a shot. I only changed black topbar, and color of windows to charcoal grey instead of light grey.

    2. I also wanted a youtube widget on my desktop as I needed youtube to stay at the front as i was watching a tutorial video on a program i was using a Safari small window it would obviously jump to the back when i started clicking on my program. So SECRETS which is actually a pretty cool and well reviewed preference modifier was added and i checked a lil box and beautiful I had widgets on my desktop.


    Have no idea if this is what caused my problem but I guess i never used any of the F1-F12 keys right after i did the themeing and preference mods so it wasnt until later that I noticed antytime i wanted to use volume+/-, screen/keyboard brightness, next track etc I now have to press the function key for them to work.... so i dont know if it was the mods that did something or if I somehow engaged this reverse option somehow in the OS but its friggin annoying... yes friggin.

    please help.

    NOTE: both programs have been uninstalled, and computer restarted and problem is still present
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    System Preferences > Keyboard ...

    Uncheck the box about function keys

    Screen Shot 2013-02-26 at 10.49.59 PM.png
     
  3. monokitty macrumors regular

    Joined:
    Sep 16, 2011
    #3
    System Preferences > Keyboard.

    Uncheck the first option.

    Edit: Ha! Beat me to it!
     

    Attached Files:

  4. Koobs123 thread starter macrumors member

    Joined:
    Jul 29, 2008
    #4
    You my man are a genius of tremendous proportions... I feel like i have to re-pay you somehow

    Ill send you 1000 dollhairs via paypal if possible. If they wont accept my dollhairs then I hope a simple Thank you will be enough.

    thanks again.
     
  5. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #5
    Yes, yes, I know. ;)

    :p

    Anytime.
     

Share This Page