Help -- Gray screen after restart between Disc 1 and Disc 2 of OSX reinstall

Discussion in 'Mac Basics and Help' started by knidsrok, May 24, 2009.

  1. knidsrok macrumors newbie

    Joined:
    Mar 28, 2009
    #1
    Hi. So last night, my Macbook started to show a folder icon with a question mark on it when I tried to boot it up. I tried to restart a couple different ways, using the Install disc, and when nothing worked, decided to reinstall OS X entirely.

    Well, after the first disk finished installing, it said to restart the computer and be prepared with disc 2. Unfortunately, after the restart, I just get a blank gray screen, while my optical drive makes short repetitive noises.

    Any advice on how to get the reinstall to work right?
     
  2. zmttoxics macrumors 65816

    zmttoxics

    Joined:
    May 20, 2008
    #2
    Could be your second disk is bad, or the drive is having troubles reading it. With out another disk set to test with, you should take it to an Apple repair specialist to look at it.
     
  3. knidsrok thread starter macrumors newbie

    Joined:
    Mar 28, 2009
    #3
    I never actually get to the point where it prompts me for the 2nd disk. It restarts with the disk 1 still in it, and then can't boot.
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    If the drive is visible in Disk Utility, you could consider formatting the drive first and then reinstalling but that throws any chances of recovering data out the window through an archive and install. If the erase & install is not an option, I would go with zmttoxics' suggestion to bring it in, because unless you have another Mac you can't used FW target disk mode to pull anything off, and it is likely a bad hard drive.
     
  5. knidsrok thread starter macrumors newbie

    Joined:
    Mar 28, 2009
    #5
    I do have another os x pc, but it doesn't have a firewire port and I don't have a firewire cable. Is there a way to use an ethernet cable in target disk mode?
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Well Target Disk Mode specifically is FW only. I suppose if you were able to boot into the OS you could set up file sharing over Ethernet but if you can't get past the gray screen its not going anywhere.

    Now the noises you're hearing from the optical drive could indicate that it is having trouble kicking out the first disc to make room for the second, have you tried holding the Eject key or the trackpad button to force eject, barring anything physically blocking the slot?
     
  7. knidsrok thread starter macrumors newbie

    Joined:
    Mar 28, 2009
    #7
    I tried rebooting while holding the trackpad button, ejected disk 1, and put in disk two -- blinking ? folder. I also tried putting disk 1 back in, and it booted up and wanted me to install again. I tried telling it to boot from my hard drive volume, and got the blinking ? folder.
     
  8. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #8
    Yeah, that agrees with my earlier assessment of there being something busted with the drive itself. No fix other than a replacement drive will do.
     
  9. naonao macrumors newbie

    Joined:
    Jul 17, 2009
    #9
    Blast from the Past

    This is a long shot as the last post was in May 2009.

    I'm having the same problem.

    I get through installation of Disk 1 without a problem.

    The laptop is rebooted and I just get a grey screen.

    No ? Folder or anything.

    Eventually, after about 2 minutes, Disk 1 is spit out.

    Then gray screen for hours (I've waited 4 hours so far ..)

    I got a brand new HDD and I've tested it on a Windows laptop so I know it's working.

    I wonder if anybody can shed some light on the problem?

    Many thanks,

    Nao
     
  10. naonao macrumors newbie

    Joined:
    Jul 17, 2009
    #10
    Correction:

    Having ejected Disk 1, the ? Folder icon appears after about 10 minutes of waiting.

    Nao
     

Share This Page