Help! How to Delete ALL Music off of iPhone 6? Why do I have rogue songs...

Discussion in 'iPhone' started by Starfyre, Oct 9, 2014.

  1. Starfyre, Oct 9, 2014
    Last edited: Oct 9, 2014

    Starfyre macrumors 68030

    Starfyre

    Joined:
    Nov 7, 2010
    #1
    I disabled showing any of the music on iCloud and went to:

    Settings -> General -> Manage Storage -> Music -> Delete All Songs..

    Even though music says "No Data" When I go to my music app I have 16 songs...

    How can I get rid of the rogue songs?
     
  2. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #2
    Open music app -> click 'songs' on the bottom -> swipe left and press 'delete' on each song you want to get rid of.
     
  3. Starfyre thread starter macrumors 68030

    Starfyre

    Joined:
    Nov 7, 2010
    #3
    I swiped from right to left, there is no 'delete'...
    I just downloaded a song I had already purchased from itunes, I see it in music. When I swipe right to left, I see the "Delete", but for those rogue songs, there is no "Delete" that appears..
     
  4. gibbz macrumors 68030

    Joined:
    May 31, 2007
    #4
    I had this happen when I clicked to play songs that were in the cloud (from iTunes Match). Choosing delete from settings didn't remove them, nor did I have the option to swipe->delete the songs. This only happened to songs for which I didn't explicitly click the download button. I haven't found a solution yet.
     
  5. paulgandersman macrumors regular

    Joined:
    Jul 4, 2010
    #5
    lemme guess, its the U2 album. THEY WON'T LET YOU DELETE IT!

    #u2gate
     
  6. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #6
    Hrm...

    Have you tried settings - itunes & app store -> show music : off?
     
  7. Starfyre, Oct 9, 2014
    Last edited: Oct 10, 2014

    Starfyre thread starter macrumors 68030

    Starfyre

    Joined:
    Nov 7, 2010
    #7
    Yes. That is how I saw the rogue songs.

    ----------

    I managed to delete it! Heres to others having this problem.

    I don't use match either, but I was able to delete the songs by turning on show all songs (including ones from cloud) redownloading the songs I already had (even though there were duplicate rogue songs listed). After the duplicate/rogue songs were finished downloading, I changed my settings to show "only songs on phone and not from cloud). I was then able to do the swipe delete that Hal mentioned.

    Apple sure could have made this easier and less glitchy. Thanks guys!
     
  8. Hal~9000 macrumors 68000

    Hal~9000

    Joined:
    Sep 13, 2014
    #8
    No problem, not that it seems I was great help anyways ;)

    Glad you were able to solve your issue :)
     

Share This Page