HELP. iBook not seeing HD!

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
Hello all! When I woke this morning, my fiance informed me that she "nuked" her HD on her iBook. I calmly came downstairs to find that the finder did not complete its lauch-the HDs were not visible. The dock comes up, there is a background and the menu bar, but no taska can be performed, and the Spinning Beach Ball of Death just sits there. I restarted ftom the 10.2 disks and ran first aid, and then started in Apple-s with fsck -y, it said nothing was wrong every time, but when I went back to X, nothing appears again. Everything seems to run fine in 9. Coincidentally, all of this happened right after she downloaded the Safari update.

Please help with any suggestions that don't involve buying software first, and then money-spending solutions later. Thanks people!

Regards,
Gus
 

MacBandit

macrumors 604
Re: HELP. iBook not seeing HD!

Originally posted by Gus
Hello all! When I woke this morning, my fiance informed me that she "nuked" her HD on her iBook. I calmly came downstairs to find that the finder did not complete its lauch-the HDs were not visible. The dock comes up, there is a background and the menu bar, but no taska can be performed, and the Spinning Beach Ball of Death just sits there. I restarted ftom the 10.2 disks and ran first aid, and then started in Apple-s with fsck -y, it said nothing was wrong every time, but when I went back to X, nothing appears again. Everything seems to run fine in 9. Coincidentally, all of this happened right after she downloaded the Safari update.

Please help with any suggestions that don't involve buying software first, and then money-spending solutions later. Thanks people!

Regards,
Gus
Does she still have a home folder? Did you repair permissions?
 

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
Booting into OS 9 shows that she still has everything there, and the OS X partition boots up fine while in 9, so it's a X-specific problem. I haven't been able to repair permissions from X.

Regards,
Gus
 

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
Yeah, I tried that, but that option was "greyed out". It would only let me repair with first aid. Wierd, huh?

Regards,
Gus
 

MacBandit

macrumors 604
Originally posted by Gus
Yeah, I tried that, but that option was "greyed out". It would only let me repair with first aid. Wierd, huh?

Regards,
Gus
After you repair with first aid or repair permissions you have to click on the hard drive then back on the icon with your drive name again. I don't know why this is so it just is. It refreshes the selection basically.
 

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
Yup, tried that too. I just restarted again from the CD and am running permissions repair right now. I'll let you know what happens when it is done.

Regards,
Gus
 

benixau

macrumors 65816
Oct 9, 2002
1,307
0
Sydney, Australia
do the dirty deed :eek:

backup!!!!!!!

and then do the other deed and re-install. Archive and install

why? That way you can bring as much as you want over from the previous system and all will be ok.


good luck
 

GeeYouEye

macrumors 68000
Dec 9, 2001
1,651
4
State of Denial
She probably tried to print from Safari.

Here's the updated way on how to fix it.

1. If you can boot in single user mode, do it. Otherwise, FWTDM to another Mac running 10.2 and use the terminal to get to your HD.
2. type (no quotes) "sudo touch /tmp" hit return, then enter your password and hit return again.
3. type "sudo ln -s /private/tmp /tmp" return, enter password, return.
4. Type reboot and hit return (in Single user mode) or quit, disconnect from FireWire, and reboot.

Hope it works.

PS. That's LN, not IN or 1N.
 

benixau

macrumors 65816
Oct 9, 2002
1,307
0
Sydney, Australia
no it think it was /tmp/....

i am pretty sure of it. that is where all of the tmp print files are stored.

basically as it deletes the print job it deletes the link along with it. how mac like :)

anyway that what i understand. but, it iss still tmp i am pretty sure of that.

can someone confirm so this guy doesnt damage this artwork any furthur.
 

GeeYouEye

macrumors 68000
Dec 9, 2001
1,651
4
State of Denial
Originally posted by benixau
no it think it was /tmp/....

i am pretty sure of it. that is where all of the tmp print files are stored.

basically as it deletes the print job it deletes the link along with it. how mac like :)

anyway that what i understand. but, it iss still tmp i am pretty sure of that.

can someone confirm so this guy doesnt damage this artwork any furthur.
That's why I said hold off on it. My updated instructions are up, and yes, you were right, it was /tmp.
 

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
I will try doing what you said, but I know that she didn't try printing from Safari. I watch the boards pretty carefully and had warned her already. The last couple of days she has been having problems in the Finder. All of a sudden, the Finder would refuse to let her drag items on the desktop. A restart would fix it for a while.

I have the Finder window and Dock working now, but the HD will still not show up. She just backed up last night before this crash, so I will Archive and Install. I just wanted to see if there was an easier fix first. Thanks guys!

Regards,
Gus
 

benixau

macrumors 65816
Oct 9, 2002
1,307
0
Sydney, Australia
look, gus. safari is a great browser, i have only one porblem with it and that is it crashes my mac when i tell it to sleep and safari is open.

but safari has some serious problems. ok so they are more serious than that but still ...

unless you know about editing the MBR and OS X boot files from OS9 then i think a re-install is in order.

sorry we couldnt have been any more of a help.


ps. try the above suggestion for /tmp anyway. never know ... :)
 

GeeYouEye

macrumors 68000
Dec 9, 2001
1,651
4
State of Denial
Originally posted by Gus
I will try doing what you said, but I know that she didn't try printing from Safari. I watch the boards pretty carefully and had warned her already. The last couple of days she has been having problems in the Finder. All of a sudden, the Finder would refuse to let her drag items on the desktop. A restart would fix it for a while.

I have the Finder window and Dock working now, but the HD will still not show up. She just backed up last night before this crash, so I will Archive and Install. I just wanted to see if there was an easier fix first. Thanks guys!

Regards,
Gus
Hmm... that sounds like a crash of coreservicesd. that's generally caused by a bad disk image being mounted, or occasionally bad RAM or HD blocks.
 

iJon

macrumors 604
Feb 7, 2002
6,559
46
just whip out those disks and reinstall mac os x. you dont need to backup anything unless youw ant. it will take you 20 minutes to fix this. in my opinion easier than all the terimal stuff. but do whatever works. its nice to listen to these people and see all the different ways to fix your comptuer.

iJon
 

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
Originally posted by GeeYouEye


Hmm... that sounds like a crash of coreservicesd. that's generally caused by a bad disk image being mounted, or occasionally bad RAM or HD blocks.
Yeah, that was my first thought too. I've seen a Finder.app get corrupted in the past (10.1.x) and I could just copy a good Finder.app from another machine, but 10.2.x won't let me do this. She just Archived and installed. Thanks for all of the input.

Regards,
Gus
 

Gus

macrumors 65816
Original poster
Jan 1, 2002
1,078
0
Minnesota
Yeah, well unfortunately I bought Drive 10 when it first came out, and it's pretty worthless at $69. We Archived and Reinstalled, and it works fine now. Guess, I need to invest in some software though.

Regards,
Gus