Help? iMac (27" Core i5 late 2010) refuses to go to sleep on its own.

Discussion in 'iMac' started by gospel9, Apr 4, 2011.

  1. gospel9 macrumors regular

    Joined:
    Sep 20, 2008
    #1
    I actually have been living with this problem since I purchased the iMac from day 1. I never really had the time to find the root of the problem, although I guessed it was probably because of some software.

    So here's the problem:

    1) Display dims and turns off properly at the correct time, but
    2) the iMac never actually sleeps; you can still hear hard drive noises and, upon moving the mouse the screen immediately turns on with 0 delay, with all the networking apps still online (compared to a normal Manual Sleep, apps like Adium and Skype logs off).
    3) Computer goes to sleep correctly if given the sleep command manually.


    Yes I have:
    1) already Repaired Disk Permissions.
    2) already Reset the SMC.
    3) already tested on a brand new user account; problem persists.
    4) tested with all applications off...
    5) tested using SMART Utility, screenshot here:


    [​IMG]

    [​IMG]



    There was another problem with this HD, when iMac arrived out of the box, it wasn't able to allocate 40GB for a Windows Bootcamp partition. Which was kind of weird, I know.

    This is starting to look like a hardware issue which has me worried. So what should I do at this point? I don't really have the time to send in my iMac for an extended period of time, as I do need it for work.
     
  2. Drewbie macrumors member

    Joined:
    Aug 27, 2010
    #2
    well its a system wide issue for sure... sleep mode is working from the apple menu i assume

    if your keyboard is wired try disabling bluetooth and letting it fall asleep and seeing what happens.
    also try turning the airport off and doing the same, one of those could be the culprit

    I would also try a PRAM reset and see if that helps

    /library/preferences/system configuration/powermanagement.plist could be removed and tested after the system has recreated the file (reboot to get it back)

    also in the same directory i have a com.apple.AutoWake.plist

    it doesn't look like it stores much information and doesn't sound like it will help, but if you have it, move it to the desktop and rule that out as the culprit
     
  3. gospel9 thread starter macrumors regular

    Joined:
    Sep 20, 2008
    #3

    Thanks for the help, unfortunately it didn't help :(

    I did each and everyone of the things you mentioned twice, just to make sure. Even removed the battery off of the Apple Keyboard and Magic Mouse.

    Yes the computer goes to sleep normally when accessed from the Apple menu.


    Does anyone have any more ideas? I would like to check out daemons but I haven't really got a clue about what to do.
     
  4. gospel9 thread starter macrumors regular

    Joined:
    Sep 20, 2008
    #4
    Ok, so today I have removed every single Daemon from /Library/LaunchDaemon folder as well as removing every single Login start up application.

    Tested in my admin account as well as a brand new empty test account, issue still persists...

    Here are all the apps running,

    Screen shot 2011-04-12 at 12.06.13 AM.png


    iMac still refuses to sleep on its own. Is it possible for this to be a hardware issue?
     
  5. Polydactyl macrumors member

    Joined:
    Oct 25, 2009
    #5
    A lot of people have had similar issues. The best advice I saw was to download PleaseSleep (free) and forget about trying to solve it since you're likely to drive yourself mad. The problem is, there are so many things that could be waking your computer/preventing sleep.

    PleaseSleep enforces your current sleep parameters and works flawlessly.

    http://www.dragonone.com/products/macosx/pleasesleep/
     
  6. OliverOSX93 macrumors regular

    Joined:
    Jun 26, 2010
    Location:
    Accrington
    #6
    have you tried giving it a propper belting before bed? :p (Im sorry I couldn't resist)

    go with the sleep app
     
  7. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #7
    Yes, this does occasionally happen. Resetting PRAM, Permissions etc is usually a waste of time. I've found the best thing (and most reliable!) is to physically put the machine to sleep when you've stopped using it.
     
  8. gospel9 thread starter macrumors regular

    Joined:
    Sep 20, 2008
    #8
    Thanks for the suggestion the sleep app seemed to have worked, but it is kind of annoying that I have manage this myself. For example I don't want the computer to sleep when I am accessing the iTunes sharing, and if say I am downloading big files, etc.

    Sent from my iPhone 4 using Tapatalk
     

Share This Page