Help! iPhone 3G no longer works with WiFi after being unlocked

Discussion in 'iPhone Tips, Help and Troubleshooting' started by lambo, Jan 23, 2009.

  1. lambo macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
    #1
    Hi, I attempted to unlock my iPhone 3G and during this process WiFi was working great, but after I finished the process of unlocking my iPhone, the unlock failed, and so I restored the phone.

    Now, the iPhone is having problems with WiFi, it can pick up my WiFi network and sometimes connect, but whenever I go to use any internet, it doesn't work or disappears immediately.

    I've reset the iPhone, used DFU mode, restored from an old back up, restored and didn't use a back up, reset the 'Network Settings', and nothing is working. I have another iPhone and it is picking up WiFi perfectly while my 3G still isn't working.

    If all fails, I'll just send it out to Apple for a replacement.

    Any suggestions?
     
  2. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #2
    Is the network password protected (via WEP or WPA(2))?
     
  3. lambo thread starter macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
  4. DPA macrumors 65816

    DPA

    #4
    Is the WiFi network yours or a company's that you may work for? The company may of changed the password or encryption type to say... WPA(2). Check with the company if it is a company's network.

    I guess so...

    David
     
  5. lambo thread starter macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
    #5
    No, it's my own personal network. I doubt anything has been changed since my other iPhone is picking up WiFi just fine.
     
  6. lamina macrumors 68000

    lamina

    Joined:
    Mar 9, 2006
    Location:
    Niagara
  7. lambo thread starter macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
    #7
    I already did that as stated before.

     
  8. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #8
    Just for experimentation's sake, try changing your network to an open one and seeing if the problem persists.
     
  9. lambo thread starter macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
    #9
    Well, I called Apple and they're going to send me a box and I'll ship it over to them to see if it's a hardware problem. Bleh.
     
  10. plumbingandtech macrumors 68000

    Joined:
    Jun 20, 2007
    #10
    Great. So you are going to tie up resources and add uneeded costs because you unlocked your phone and YOU messed something up.
    :rolleyes:

    Did you at least volunteer and tell them it was unlocked?

    I hope it takes several weeks to get back your phone.
     
  11. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #11
    Unlocking doesn't alter WiFi. IIRC, the OP already said he tried restoring to stock firmware...
     
  12. lambo thread starter macrumors regular

    Joined:
    Jul 6, 2008
    Location:
    FL
    #12
    Ok, I sent it into Apple and they acknowledged the problem and are sending me back a replacement.
     

Share This Page