Help! iPhoto 'Unexpectedly Quits'- and won't run anymore

Discussion in 'Mac Apps and Mac App Store' started by ealistello, Oct 5, 2003.

  1. ealistello macrumors newbie

    Oct 5, 2003
    I've been using iPhoto for 6 months- no problems until the last 6 weeks. I'm using the iPhoto and it just quits. I click on icon- reloads, no prob. Just in last 2 weeks, won't even load- just gets the library on L hand side- and then quits. I've tried the permissions, tried looking to delete iPhoto preferences (doesn't exist on my computer), tried deleting the most recent of my photos (when it was loading for me). I've read about iTunes doing this, iMovie, etc but those solutions don't seem to apply to iPhoto (or I'm too dense to figure it out.) I've been on the Mac site and no one else seems to have this problem. Only about 300 photos in library- don't want to reload iPhoto and lose all photos in app (but I'm getting close). iTunes and iMovie load ok.
  2. idkew macrumors 68020


    Sep 26, 2001
    where the concrete to dirt ratio is better
    quit iphoto

    go to home->library->preferences-> and delete it.

    open iphoto. this might just do it for you.

    if not, quit it again. move your current library to the desktop (home->photos->iPhoto Library) or some other place not in the photos folder, then launch iPhoto again.

    95% sure this will help.

Share This Page