HELP! Is there an EASY way to put an MP4 movie on an iPhone?

Discussion in 'iPod' started by 4DThinker, Apr 5, 2009.

  1. 4DThinker macrumors 68020

    Mar 15, 2008
    My wife has in iPhone. She's taking a trip and asked me to put her favorite movie on it. I convert the DVD to an MP4 file which plays fine in iTunes on the PC.

    I can't seem to get iTunes to add it to it's movie library though, and I can't get it to show up as a movie to sync with the iPhone either. I've tried adding the file to the library. I've tried adding the folder to the library. Nothing seems to work. I've tried this both on a PC and on an iMac. Both see the iPhone just fine. Both play the MP4 file just fine. Neither lets me add it to their library listing for movies. HELP!
  2. sammich macrumors 601


    Sep 26, 2006
    What program did you use to convert the DVD? Some programs like VisualHub or Handbrake have a dedicated iPhone setting so that it's guaranteed to work.
  3. ib4walrus macrumors regular

    Jul 5, 2008
  4. 4DThinker thread starter macrumors 68020

    Mar 15, 2008
    123Movies2iPod, a PC based program. Thanks for the suggestion though. I traced my problem to my iMac's tendancy to screw up USB thumbdrives when they are ejected. The movie file got corrupted. Re-ripped it, copied to a shared network drive, added it to the itunes library on the iMac, and all is well. Skipped thumbdrives altogether this time.

    Now can anyone tell me how to get iTunes to point to photos in more than one folder/directory for photos? I pick a new folder and it swaps the pics in that folder for the previous ones on my Touch. It won't list any folders in the big window no matter what I've tried so far.
  5. ravenvii macrumors 604


    Mar 17, 2004
    Melenkurion Skyweir
    Not really. I converted several movies with Handbrake using the iPhone preset settings, and for some reason they sometimes don't work (viewable in iTunes, but grayed out in the sync list for the iPhone). Don't ask me why.

    Did you eject the thumbdrive before you pull it out of the USB port? If you didn't, that's why it got corrupted.

Share This Page