Help! iTunes playing songs out of order (second album first!)

Discussion in 'Mac Apps and Mac App Store' started by majordude, Sep 26, 2008.

  1. majordude macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #1
    Aaarrrggghhh!

    What am I doing wrong?

    In "grid view", I push play album. Then iTunes 8 starts playing the second disc first when there are more than one disc!

    It isn't playing "disc 1 of 2" it plays "disc 2 of 2" and then it goes back and plays disc 1.

    Oddly, it plays the songs in the correct order (1-10 instead of 10-1)... so I have no idea what the deal is.

    Help!
     

    Attached Files:

  2. iSaint macrumors 603

    iSaint

    Joined:
    May 26, 2004
    Location:
    South Mississippi y'all, near the water!
    #2
    I only know to verify the information for the album through Info (Apple + I)


    Why does your bit rate vary so much?
     
  3. majordude thread starter macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #3
    It's Apple lossless.
     
  4. orpheus1120 macrumors 65816

    orpheus1120

    Joined:
    Jan 23, 2008
    Location:
    Malaysia
    #4
    Let's go through this checklist together with your album

    1) Highlight all your disc 1 songs -> get info -> info -> making sure under "disc number" it is "1 of 2".
    2) Under "info" tab, make sure the "Part of compilation" is "Yes"

    Repeat these steps to your disc 2.

    See if this fixes your problem.
     
  5. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #5
    :confused: I don't understand this one. It's obviously not a compilation.
     
  6. orpheus1120 macrumors 65816

    orpheus1120

    Joined:
    Jan 23, 2008
    Location:
    Malaysia
    #6
    I know what you mean.

    Enabling compilation may help in his case to diagnose the problem. He can toggle it on/off later if he wishes.
     
  7. majordude thread starter macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #7
    Hmmm. I think I spotted the problem (and I can't believe it is a problem)... but "This Is The Album Name" is not the same as "This is the Album Name" even though iTunes groups it together and knows that it is the same album. :mad:

    I just changed it to the same case and it worked. Thanks!
     

    Attached Files:

Share This Page