Help - LaCie d2 not mounting is just the begining...!

Discussion in 'General Mac Discussion' started by noahsnyc, Aug 12, 2004.

  1. noahsnyc macrumors regular

    Sep 27, 2003
    Los Angeles
    Ok, guess I'll start at the begining.

    A friend of mine and I share a LaCie d2 120GB external drive between our iBooks. He's been out of town for a couple of months and in that time I've been taking very good care of the HD, and using it quite frequently.

    Today, he installed a new replacement battery for his iPod and backed up all his music from it (he keeps little on his iBook) with PodWorks. Well, everything looked just dandy.

    Later in the evening, he went ahead and plugged the LaCie into his iBook and magically, lots of stuff was gone! Some of mine, some of his, just a disaster.

    Long story short, we found most of what was missing with Disk Rescue X, and then, again, magically, the HD stopped mounting!! It stopped MOUNTING!!!

    So, immediately went at it with Disk Utility, which gave me the ol' "The underlying task reported failure on exit (-9972)" excuse. Yeah, whatevah.

    Well, I've been running DiskWarrior on it to no avail. DW basically runs itself like it should and then comes back with a little story about not being about to rebuild the volume.

    Now, I've tried Mount Me, which actually has been working about half the time, but that's obviously not a fix. The situation is out of hand, and once Disk Warrior couldn't help me, I'm almost out of ideas.

    If only the thing could mount regularly to at least give me the ability to run Data Rescue X and start recovering stuff, that'd be the start.

    Thanks for your thoughts,

  2. mmmdreg macrumors 65816


    Apr 14, 2002
    Sydney, Australia
    I've just gotten this error. It's gay as!
    Verifying volume “Y”
    Checking HFS Plus volume.
    Checking Extents Overflow file.
    Checking Catalog file.
    Invalid key length
    The volume Y needs to be repaired.
    Volume check failed.
    Error: The underlying task reported failure on exit (-9972)
    1 volume checked
    	0 HFS volumes verified
    	1 volume failed verification
    sounds suspiciously like your problem and I haven't really gone about fixing it.. I'll see what I can do..
  3. evoluzione macrumors 68020


    Jul 19, 2002
    down the road, that's where i'll always be
    try booting into OS9 and see if it mounts as normal....really.

    i have a 120 d2 and it failed to mount on my old g4 imac in os x a few times, and i got it to work and mount again by booting into 9 where it would show up, then booting back into X where it seemed to be fine once again.

    hope it helps!
  4. mmmdreg macrumors 65816


    Apr 14, 2002
    Sydney, Australia
    Unfortunately the computer can't boot into OS9 (I think anyway.. didn't they do something against it?).. so what should be my next step? Like there *is* classic but no OS9 booting.
  5. mmmdreg macrumors 65816


    Apr 14, 2002
    Sydney, Australia
    judging from previous responses (to others) at MacRumors and elsewhere, this is one of the problems noone seems to help out with. Most suggestions revolved around booting into OS9 and back and it "miraculously" worked.

    Here's my solution:
    First i mucked around with diskutil a bit and it couldn't repair the volume (like it was there but unmounted).. I screwed around a bit doing stuff that didn't work.. and skipping a bit, I used "fsck_hfs -rfd" and it actually worked. Like it found a ******** of errors and repaird them at which point, I could mount the drive in disk utility. From then, running the diskutil repair about 5 times got rid of all the errors. Now I got one happy disk =) (except the loss of a few gigs of data =S.. but hey.. on a 500gig HD, whats a few? there was a created "lost+found" folder with a few bits in it but yeah.. it seemed that all the lost data was centred around one part which was good I guess...)
  6. gobobgo macrumors newbie

    Nov 28, 2004
    Additional Help

    My backup drive crashed much the same way as the previous posts.. I couldn't figure out how to find out the drive mapping to use the command above fsck_hfs -rfd... searched.. found this article about it

    Hope it still works when others try viewing it.

    diskutil list

    gives you a list of all devices hooked up to your computer.. and then you can find your broken device in that list.. hope it helps others. :)

Share This Page