help me delete stubborn files!

Discussion in 'Mac Apps and Mac App Store' started by wormy, Mar 3, 2003.

  1. wormy macrumors member

    Dec 5, 2002
    I installed a program that i ended up getting rid of- but I cant delete some of the .kext files it installed. it says its owned by the root. i need to delete these files because they keep causing these annoying pop up messages. my question is how can i delete these files if it wont let me trash them? i tried booting off the osx 10.2.3 dvd but it only gives me the installer menu. and i have a new machine with no os9. any suggestions?
  2. FredAkbar macrumors 6502a


    Jan 18, 2003
    Santa Barbara, CA
    Re: help me delete stubborn files!

    You have two options here. You can either use the Terminal to delete the unwanted files, or log into your computer as the root user.

    Unless you have experience with Terminal and Unix, I'd recommend logging in as root. To do this, open up the NetInfo Manager program (it's in your Utilties folder, which is inside your Applications folder). On the Security menu, select Authenticate, and type in an administator username and password. Then, on the Security menu, select "Enable root user." It might ask you to make a new password for the root account, so do that.

    Then log out, log back in again as the root user (you might have to click the icon for "Other user" in the login screen...once it gives you the boxes for user and password, type in "root" for the name and for the password, use whatever password you created earlier). Once you are logged in as root, you can delete whatever you want.

    Sorry this is such a long answer, but in my opinion it's the easiest way to do it unless you have unix experience.

  3. Datazoid macrumors regular

    May 10, 2002
    Third option...change the permissions using the "Get info" screen. You will first have to change the "owner" from "system/root/etc" to your user name. This will require clicking the lock and entering your administrator password. Then make sure that the permission is set to "read & write". After that, just delete the file.
  4. FredAkbar macrumors 6502a


    Jan 18, 2003
    Santa Barbara, CA
    Ah, right, I forgot about that one. That's probably the easiest.

  5. wormy thread starter macrumors member

    Dec 5, 2002
  6. wormy thread starter macrumors member

    Dec 5, 2002
    can't get it to work

    I finally had a chance to try your suggestions and I still cant delete this annoying .kext file. it says "it cannot be moved to the trash because it cannot be deleted."

    I tried the info and setting it to read & write under my permissions and it didnt help. And I tried to use the Net Manager but that didnt seem to work either. I tried using what little Unix I know in the terminal but I cant even manage to get into the directory.

    This happened when I installed it on my old computer, but then I simply booted into OS9 and deleted it- no prob. Any other suggestions? Is there a way to boot off of the OSX dvd?
  7. altair macrumors regular

    Nov 22, 2002
    Seattle, WA
    alright, here we go

    So no one has given you the way to do it in terminal, however I think its pretty easy.

    Here is what you want to do, find your nasty file/folder on the hard drive. Open Terminal and type 'rm -r' then drag the folder/file that you want to get rid of into the terminal. Then you will see it says 'rm -r /user/blah/crappyfolder'. If it doesn't say this, for the love of god don't push enter. Make sure that it says rm -r then the folder that you want to kill. rm -r will recursively remove everything in the folder that you select, so EVERYTHING, which can be bad if you type the wrong thing.

    If it still doesn't let you, then do the same thing but with 'sudo' in front of 'rm -r' this will then ask you for a password, and it is just your admin password.

    This will work, just please don' t hit enter if you are not positively sure it is the correct folder/file.

  8. wormy thread starter macrumors member

    Dec 5, 2002
    ok i'll give it a try when I get home from work and let you know how it goes. just have to make sure not to delete the whole extensions folder. i think that would be bad haha.

  9. spacepower macrumors member

    Jul 8, 2002
    i know another way

    if you have a copy of dropstuff...
    select in the prefs to delete the orginal after stuffing. so then stuffit/dropstuff deletes the originals and then you can delete the compressed archive. i am not sure if it works for items own by root. but it works great if you have a bunch of files and don't feel like change their permissions individually.

  10. evoluzione macrumors 68020


    Jul 19, 2002
    down the road, that's where i'll always be
    can't you just boot into OS 9 and delete the trash that way???? I think you may have to move it out of OS X trash and then put into the trashcan when you've booted into OS 9. I had a troublesome file (actually a whole load of them) and that worked for me, when using the CLI didn't (still can't work that one out)
  11. yzedf macrumors 65816


    Nov 1, 2002
    $ sudo rm /lame/file/here

    this is from the terminal, and you don't type the $-sign...

    use OS X... love OS X...

    forget the lame-o OS 9 junk. apple chose a BSD base for a reason or two - power, and stability!
  12. MrMacMan macrumors 604


    Jul 4, 2001
    1 Block away from NYC.
    You have all deglected the easiest way.

    The app method.
    Get 'Delete It'
    Open app.
    Find fild
    Hit delete
    Enter root password

Share This Page