Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Help me please! Can't reinstall macOS

Raymond Keating

macrumors newbie
Original poster
Oct 2, 2020
1
0
Hi,

Yesterday I tried to factory reset my mid 2010 MacBook Air to sell it. I went into macOS utilities and erased the hard drive, then I tried to reinstall macOS Yosemite from the Apple Store. However, it forced me to log into Apple ID, and I don't know the password, I think it's locked out. I have tried to recover this Apple ID before, and it didn't work. Anyways, I assume there is some way around this, so I went into internet recovery. I waited for internet recovery to install, and all it did was change the OS to Lion (10.7), and I was still stuck at utilities, and unable to install because the Apple ID i used on the MacBook was locked out. When I try using my other Apple ID to reinstall macOS, it says "this item is temporarily unavailable" every time. So I tried installing Yosemite onto a bootable USB, using DiskMaker X. At this point, the only way i can access utilities is to go into internet recovery every time, if i don't, the macbook opens with a flashing folder with a question mark. So when i go into disk utility and try to open startup disk to boot from the USB, startup disk is blank. When i try to boot into startup manager using alt (option), nothing happens, and it goes straight to the flashing folder.

I am no noob when it comes to fixing stuff, but I literally think I bricked my MacBook and now I have no laptop for school. Please help!
 

benshive

macrumors demi-god
Feb 26, 2017
563
4,970
United States
Worst case scenario I think Apple support can get you past that if you provide them proof of purchase. If it works the same way activation lock works on iOS and watchOS then there's no way past it without the account info. But maybe Audit13's suggestion will work.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.