HELP PLEASE: lost all of my user stuff (logins, email accounts, layout preferences...

Discussion in 'MacBook Pro' started by Sethgun, Dec 21, 2010.

  1. Sethgun macrumors newbie

    Joined:
    Oct 27, 2010
    Location:
    Melbourne, AU
    #1
    Hi guys,

    I was just doing a superduper backup which failed halfway through because i didnt realise my wd passport drive that was plugged in was auto backing stuff up and there must have been a conflict.


    Now, I dont know what to do. Email accounts.gone. Any registered apps, still there but reg details gone, any and all system preferences (like trackpad setup just came to mind) gone. Dock and all the items in it and crap I made to ,make it look fancy. gone. Stuff that loads at the stuff...gone.


    What the hell?>>>>> I know this must have to do with my user directory but wtf???? I know my timemachine backup is fine as i did one before all the problems, but is my superduperbackup screwed? I cant stress how screwed I am, I got reports due right before xmas and im like at square 1 now. PLEASE, if anyone can help with any suggestions, my ears are wider than wide open.

    Cheers in advance :)
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Err.. if you were backing up your machine via SuperDuper, why have you lost anything on the source drive? It's pretty much a one-way street...

    ...perhaps you could explain a bit more clearly? Is the external drive partitioned? Which drive is screwed up?
     
  3. Sethgun, Dec 21, 2010
    Last edited by a moderator: Dec 21, 2010

    Sethgun thread starter macrumors newbie

    Joined:
    Oct 27, 2010
    Location:
    Melbourne, AU
    #3
    sorry, external disk is just for backups and storage but backs up my user directory whenever it hooks up (extra precaution) I also have superduper making a complete image of my drive on one of the partitions of the external drive so yes, the external drive is partitioned in 2. My main ssd drive is for everything, and i have a second drive built in for my user directory. All of my user directories look empty EXCEPT for one of the backup partitions, but that is only 13gb!!!!

    EDIT:

    time machine backup doesnt have my user directory either as i store my user directory on another internal drive other than my ssd dammit!
     
  4. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #4
    I still don't understand why your user preferences are screwed up. Why/how was your external drive writing to the second internal drive with your preferences on it?
     
  5. Sethgun, Dec 21, 2010
    Last edited by a moderator: Dec 21, 2010

    Sethgun thread starter macrumors newbie

    Joined:
    Oct 27, 2010
    Location:
    Melbourne, AU
    #5
    actually apologies, my user directory is intact in time machine. When I try to restore it to my hdd (NOT my ssd drive) id doesnt let me because it says its needed by osx. Before trying this, do I have to go to my account advanced settings, change the user directory location to whatever bogus one is on my ssd, THEN delete the corrupt on on the other hdd then copy over the good one from time machine, fix permissions and all should be like red licorique?

    hey miles. Before i figured out u could select ewhat files to back up with carbon copy cloner, i was using superduper (and still do) as well as time machine (up until tonight i had no idea time machine backs up your user drive even though its not on the same drive ie. EVERYTHING BUT user drive is on my ssd, USER drive is on a seagate momentus hybrid ssd). While it was performing a superduper backup, i had plugged this WD passport drive in which i hd set to auto backup some important files (as well as my user dir-3 times over cautious).

    Now it turns out for straight backing up my user dir, i might as well use carbon copy c;loner to selectively backup the directories i want backed up. Just so happens superduper stopped with an error when the wd passport drive started doing its thing.

    Looking further, THERE was a User directory tjhat I thought was legit till I realised it was only 13gb. When I had another look at time machine...User directory is there with stuff I was editing on tonight, so thats the current and good one (so it seems). Sorry im typing like a spastic bc im freaking out lol.

    Do i need to change my user directory to an empty one like whats on my ssd...delete the corrupt on on my hdd, Copy the good one from time machine....repoint my user directory to THAT one...run permissions and all is like my favourite edible pasttime?

    Cheers for your help so quickly, its 2:30m here lol
     

Share This Page