HELP! Regarding to iPhone 4s store

Discussion in 'iPhone' started by PhilipNY, Jan 23, 2012.

  1. PhilipNY macrumors newbie

    Joined:
    Jan 23, 2012
    #1
    Hi Friends
    Two days ago, I bought an app named "Flashlight" ($0.99), after that, every time when I bought no matter free or paid app from iPhone store, a dialogue just jumps out on the home screen,

    said "Unable to Purchase: 'Flashlight' could not be purchased at this time. please try again later."
    (But actually, I already bought this app, and it works well.)

    After this dialogue disappears, the new app downloading procedure just starts, and seems everything is fine. however, this is very annoying.

    I have no idea what's wrong with it.
    Please see the pic
     

    Attached Files:

  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Delete the app sign out of the store then sign in and repurchase. It'll be free.
     
  3. PhilipNY, Jan 24, 2012
    Last edited: Jan 24, 2012

    PhilipNY thread starter macrumors newbie

    Joined:
    Jan 23, 2012
    #3
    Thanks Gav2k, it worked, but keeps happening again

    it worked, but now keeps happening again
     
  4. artguy10 macrumors member

    artguy10

    Joined:
    Jun 12, 2009
    #4
    Hi Philip, I'm having the same problem on my 4s. :( Screenshot: http://i.imgur.com/h41Kl.png

    Apple Care suggested syncing with iTunes and setting iTunes to not sync apps but that didn't help. They also suggested resetting all the settings on the iPhone but I'm afraid to do that...
     
  5. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #5
    I've just started getting this error to....

    [​IMG]

    I have no Idea what "The Lions Roar" is!? 2 others? all my apps download fine. :(
     
  6. Zxxv macrumors 68040

    Joined:
    Nov 13, 2011
    Location:
    UK
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    I'm getting this too with some free language apps. I deleted them. Now I keep getting that message.

    Weird.
     
  7. iPhone1 macrumors 65816

    iPhone1

    Joined:
    Apr 2, 2010
    Location:
    San Diego, CA
    #7
  8. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #8
    Getting similar error occasionally on iPad 2, not jailbroken.

    I've deleted the app in question, and no errors so far. Have not tried reinstalling the app.
     
  9. saberahul macrumors 68040

    Joined:
    Nov 6, 2008
    Location:
    USA
    #9
    Yup got it for around 2 weeks 3 weeks ago (doing the math, it stopped last week, I guess I could have said that itself but confusion is always friendly :p )

    Anyhow, it has stopped now. What I did (which I think fixed it) was restore my iPhone from my latest backup (taken before restore began).
     
  10. Stanjara macrumors member

    Joined:
    Apr 15, 2011
    #10
    hmm

    Happened to me also...but i didn't do anything....and it stopped by itself.
    That was two days ago...also app store was very sluggish. Today it is fine.
    Probably something with apple servers
     
  11. Zxxv macrumors 68040

    Joined:
    Nov 13, 2011
    Location:
    UK
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    Still happening here. App isn't installed. I deleted it. It's obvious I dont want it. Oh well. Sure it'll get fixed at some point.
     
  12. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #12
    Its not happening anymore after I set my itunes to sync my apps. Something I haven't done in ages so it put a load of crap back on the phone which I just removed and cleaned up.
     
  13. Zxxv macrumors 68040

    Joined:
    Nov 13, 2011
    Location:
    UK
    #13
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    I think I unchecked that. Infact I don't think iTunes syncs anything. Good to know there's a fix...but do much for not needing a computer anymore :(
     
  14. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #14
    Yeah, Was a bit of a bummer but it was to annoying to not bother doing it.
     
  15. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #15
    Ahhhhhhh its back!!! :mad:

    "Lions Roar" that pops up isn't even an app in the appstore???? :(
     
  16. Zxxv macrumors 68040

    Joined:
    Nov 13, 2011
    Location:
    UK
    #16
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    ****ing Hello German!!!!!! Aggh I deleted it. What gives :(
     
  17. ogs123 macrumors member

    Joined:
    Feb 16, 2011
  18. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #18
    ahh ok. Think i'm going to go through all my purchases to get ri do f this blooming thing!
     
  19. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #19
    Well I went to the iBook app on my phone and 3 things disapeared which must have been removed when synced.

    I tried to download another app and the message didn't come up. *touch wood* it should be ok.

    Still have no idea what that book it. Never even seen it and I'm the only one who uses my ID. :confused:
     
  20. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #20
    Well after nothing working I went for the restore. (I was sick of this pop up considering I didn't even download it.)

    Any way, Synced the phone before I restored. Everything ok. Went to restore and a message came up with something along the lines of "5 apps (or something like that) have not been synced. If you restore now these items will be removed from your phone" Yes ****ing please!

    Now that I have restored the message has vanished.

    Fingers crossed that fixed it.
     
  21. Zxxv macrumors 68040

    Joined:
    Nov 13, 2011
    Location:
    UK
    #21
    I'm getting - hello German and 6 other apps can't be installed at this time. Duh I removed them that's why! Agh!!!
     
  22. MonkeySee.... macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #22
    Unfortunately this will haunt you until you restore.
     

Share This Page