Help - spinning wheel of death! :confused:

Discussion in 'General Mac Discussion' started by entelechy, Nov 23, 2004.

  1. entelechy macrumors newbie

    Nov 9, 2004
    Hi All,

    I'm new to this forum, and still have much to learn about Macs - though I love them dearly and they've changed my life! I have a Powerbook G4/667 and recently wiped & rebuilt everything to eliminate my OS9 partition and open up some more room.

    Everything went well and I was back up and running. After reading about all the problems with OS 10.3.5 & 6, I took the system back up to 10.3.4.

    As a final tidying step, I ran the latest version of Tech Tool Pro to run maintenance and optimize my hard drive and external hard drive (in 3 partitions).

    I believe my internal drive is faltering, so I ran Tech Tool off an external superdrive connected via firewire to the PB and the external drive. Everything went well, but then I couldn't find any way to "eject" the Tech Tool disc from the external superdrive after running the programs. Holding down the eject button during start-up had no effect, and the latest version of Tech Tool doesn't seem to allow you to choose a different start-up disc.

    As such (perhaps ill-advised, but I couldn't think of another way), I disconnected the firewire input on a restart, so that the machine would reboot back into the main OS.

    All seemed fine, until launching certain apps which creates the spinning wheel of death. It seems pretty arbitrary, but every time I attempt to launch Safari, iChat, Disk Utility (to repair permissions), Mail, Tech Tool (installed), iCal, and the Address book, it just spins endlessly. Other apps such as iTunes, iPhoto, Word, Photoshop, Internet Explorer, Font Book, Macromedia, etc. are all fine.

    I'm completely baffled. Running the latest versions of Disc Warrior and Tech Tool from the internal drive (which worked fine) had no effect.

    Any help or advice would be MUCH appreciated, as I really hope I don't have to rebuild everything again (I had to start from Jaguar discs). A friend thought it might be some bad RAM, but I haven't changed it for a year and it's been fine. I did, however, just order some more RAM from Crucial, and installed it last night - works fine, but no changes in regard to the above.

    Thanks in advance!
  2. Daveway macrumors 68040


    Jul 10, 2004
    New Orleans / Lafayette, La
    this is very confusing to me, but adding more good ram usually eliminate the wheel. Also, im no expert on the "open firmware" you can boot up into, but can you eject externals from there?(bootup holding: apple, option, o , f)

Share This Page