HELP! TextEdit AutoSave can't be disabled on 10.8.5, it's ruining my originals!

Discussion in 'OS X Mountain Lion (10.8)' started by Joseph Farrugia, Feb 1, 2014.

  1. Joseph Farrugia macrumors regular

    Joined:
    Jul 31, 2011
    Location:
    Malta (EU)
    #1
    I'm a professional using my MBP for work, AutoSave in TextEdit is overwriting my original files. I've recently installed 10.8 on a partition on my SSD, & have downgraded (yep!) to it some time ago to get better used to it (I have no PPC apps, but still keep SL on another partition of my 512GB Crucial SSD)

    I've tried the Terminal Hacks to disable AutoSave on TextEdit (hint: it needs two Terminal commands for TextEdit), but apparently Apple decided to bugger everything up in 10.8.5, as the hack doesn't work.

    I've set my mac so that TextEdit will open .doc files, it's still faster than opening them in Word even though I have an SSD.
    Here's the problem:

    1) After opening a simple .doc file in TextEdit, I convert it to Plain Text without saving.
    Screen Shot TextEdit Orig file doc 1.jpg

    2) As soon as I press OK, TextEdit overwrites my original .doc file, destroying it without my permission, & turns it into a .txt file without my ever having used the "Save" or "Save As" menu item:
    Screen Shot TextEdit Orig file ruined 2.jpg

    This is unacceptable behaviour, a step backwards from TextEdit 1.6 that existed on SL. It's one of the many reasons many working pros are still worried by the post SL OS releases, worried that our work is destroyed without our knowing. (Lloyd Chambers has articulate explanations on his site, I won't delve into it here).
    I only noticed 'cos I had Finder open at the same time.

    If somebody knows a solution I welcome some help, no "Versions" though please (the usual Terminal hacks referenced here on MR or on OSXdaily do not work),
    otherwise let it serve as a warning to fellow forum members.
     
  2. Let's Sekuhara! macrumors 6502

    Let's Sekuhara!

    Joined:
    Jun 30, 2008
    Location:
    日本
    #2
    I feel your pain. I think what you are describing is the implementation of the feature known as Versions. I detest Versions so much I skipped Lion and although I begrudgingly adopted Mountain Lion I am stubbornly using TextEdit 10.6 since it's the only usable version left. I copied the app over from Snow Leopard. The only buggy behavior I've noticed is that sometimes a normal Save triggers a text encoding error so you need to Save As instead. But still it's way better that dealing with the nightmare that is Versions.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    I'm in agreement with the post above.

    I, too, continue to use TextEdit 1.6 because it still offers the "save as" menu choice. I chose to rename the older copy of TextEdit to "TextEdit 1.6" so that it can be easily identified. Be aware that sometimes you may find documents open automatically into the -new- TextEdit, which you don't want to happen. You may have to get used to opening documents by "right-clicking" on them, or by "dragging and dropping" on the TextEdit 1.6 icon in the dock. You'll have to make some adjustments and find "what works" for you.

    If this isn't an acceptable solution for you, you might try some other text editor apps out there, as well.
     
  4. Let's Sekuhara! macrumors 6502

    Let's Sekuhara!

    Joined:
    Jun 30, 2008
    Location:
    日本
    #4
    Thanks.
    You can prevent your files from opening in the new TextEdit by right clicking on a .txt file in Finder, choosing Get Info (Cmd I).
    Open With...
    Choose TextEdit 10.6.app
    Then click [Change All]
    All .txt files will now be opened in TextEdit 10.6

    Repeat for any other file types you use TextEdit for (.html, .doc, etc.)
     
  5. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #5
    Just a comment on the reply directly above this one.

    I've tried that, and found (to my consternation) that sometimes files STILL open in the NEW TextEdit, regardless if I've attempted to use the "change all" fix in the get info window...
     
  6. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #6
    This little pref-pane app does a good job of changing the default application for opening files.
    It appears to do a better job then the usual 'get-info' method, and it still works well with ML.
     
  7. Let's Sekuhara! macrumors 6502

    Let's Sekuhara!

    Joined:
    Jun 30, 2008
    Location:
    日本
    #7
    Jeez, you're right! Arrrrrrgh! I just found this out today. How aggravating...
    It's like the OS X team has been assigned the task of pissing off us TE10.6 loyalists!
    They also went through the trouble of making it so you can't delete the newer TextEdit from ~/Applications

    I will explain how I got rid of the new TextEdit once and for all.
    Step-by-step (I'm not responsible if you screw something up in this process, just sharing what worked for me):

    1. If TextEdit is running, Quit it.

    2. Make a backup copy of TextEdit.app (the newer one we all hate) just in case. Note that when copying it out of your Applications folder you will need to hold the Option key because otherwise it will only make an alias and the file won't be copied (a limitation implying we're too stupid to be trusted managing our own apps). So yeah, make sure the green 'plus' icon appears when you click-Option-drag the app over. If you want to make extra certain, Get Info and check that the copied file's info reads "Kind: Application".
    Store this .app file somewhere you won't lose track of it. Example: ~/Documents/TextEdit 10.8 Backup/TextEdit.app

    3. Now open Terminal and type:
    Code:
    sudo rm -rf /Applications/TextEdit.app
    This deletes the app from the system level, bypassing any warnings or restrictions Finder would give. Be careful to type the file path correctly or you could end up deleting all your applications, or worse!
    Hit Return.
    You will be prompted for your user password. Type it and hit Return. For security reasons it will not show dots as you type.
    Congratulations, you have rid your Mac of the the cursed app. You followed step 2 and made a backup first, right?)

    4. Copy your Snow Leopard version of TextEdit into your Applications folder and make sure its file name is TextEdit.app
    Congratulations.
     
  8. boppin macrumors member

    Joined:
    Jun 14, 2008
    Location:
    Germany
    #8
    Hi,

    when you're converting RTF into plain text it's normal that the formatting settings will lost because plain text does not support formattings.
     
  9. Joseph Farrugia thread starter macrumors regular

    Joined:
    Jul 31, 2011
    Location:
    Malta (EU)
    #9
    Whooooosh!

    WHOOOOOSH!

    Please pretty please, can you at least read the OP, the "original post" in this case, before posting a reply; not just a phrase here or there that caught your eye? It's very insulting of you to all those who contributed to this thread.
     
  10. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #10
    Last I checked, Textwrangler doesn't pull that autosave and change extension trick on you, and it's free.
    I migrated to the fancier BBEdit years ago to avoid the very problem described in the OP.
     
  11. gumblecosby macrumors 6502

    Joined:
    Jun 22, 2010
    #11
    Would an acceptable solution be to disable versions and auto save as shown here: http://apple.stackexchange.com/ques...sable-auto-save-and-versions-in-mac-os-x-lion

    I wrote about this in another post when I had trouble enabling this tweak. Shown here: http://forums.macrumors.com/showthread.php?t=1725158

    Basically, due to sandboxing, some apps now have preferences stored in two locations (check my 2nd link for details). The tweak to disable versions will not work unless the plist file in both locations match. Was that what you were referring to when you mentioned the Terminal hacks?
     

Share This Page