iPhone Help to unlock iPhone 3GS 6.1.3 (unable to upgrade to iPad baseband)

Discussion in 'Jailbreaks and iOS Hacks' started by Narcisse, Sep 23, 2013.

  1. Narcisse, Sep 23, 2013
    Last edited: Sep 23, 2013

    Narcisse macrumors newbie

    Joined:
    Jul 20, 2012
    #1
    Hi everyone and thanks in advance for your help :)

    I have a locked (Bell Canada) iPhone 3GS iOS 6.1.3 running on baseband 05.16.08. I would like to unlock it. From what I understand, I cannot unlock it on 6.1.3 yet but I can unlock it on 6.1.2. In order to do that, I need to upgrade my baseband to the iPad baseband (06.15.00) and then downgrade it to an older baseband (05.13.04). Is this information correct?

    I tried to upgrade to 06.15.00 baseband using redsn0w 0.9.15b3, to no avail. I can enter DFU mode, but then redsn0w gets stuck saying "waiting for reboot".

    Is there another way to upgrade to the iPad baseband? Can you guys help me to unlock my 3GS 6.1.3? Is it possible to factory unlock Canadian phones?

    Thanks ! :)
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    What's the first 5 numbers of your serial number?
     
  3. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012
    #3
    Thanks for your reply!

    The 3GS was manufactured in 2010 so it won't get bricked.

    I found the answer to my question. I needed to redsn0w/extras/select ipsw/browse for predownloaded 6.0 ipsw in redsn0w before clicking jailbreak.

    Now, I have the iPad baseband. My new question: Should I do extras/select ipsw/browse for predownloaded 6.0 ipsw in redsn0w before clicking jailbreak when I downgrade the baseband, or can I simply downgrade?

    Thanks again!
     
  4. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012
    #4
    Apparently, Redsn0w forgets so you need to select 6.0 ipsw before every operation.
     
  5. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012
    #5
    Now I am on baseband 05.13.04. However, my 3GS says it's still on 6.1.3. In order to unlock on 6.1.2, do I need to downgrade the iOs to 6.1.2 or can I do it directly while jailbreaking?
     
  6. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012
    #6
    I've downloaded Tiny Umbrella but I'm having trouble with it. I've clicked "Save SHSH" and then there was a list created. On the iPhone I'm trying to unlock the list went up to 4.3 and my previous iphone it went up to 6.0. Does that mean I only have the shsh files needed for 6.0 and I can thus only downgrade to 6.0?
     
  7. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #7
    Yes, IF that shsh is valid though, auto saved shsh's by cydia are in valid.

    You can tether jailbrake with redsn0w on 6.1.3
    Then install ultrasn0w from Cydia and you are unlocked.

    Unlocking and jailbreaking are different things
     
  8. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012
    #8
    I am unable to tether jailbreak with redsnow.

    When I try to do it says: Missing keys.plist data for this build
     
  9. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #9
    Did you select the 6.0 ipsw before jail breaking?
     
  10. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012
    #10
    i got stuck at "transferring control to jailbreak" :(
     
  11. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #11
    First go to extras/select ipsw and select the 6.0 ipsw
    Then go to jailbreak and hit jailbreak, only select install cydia, nothing else, it should go through.
     
  12. Narcisse thread starter macrumors newbie

    Joined:
    Jul 20, 2012

Share This Page