Discussion in 'Macintosh Computers' started by thejazzman10, May 14, 2004.

  1. thejazzman10 Guest

    hello, ive tried posting this, but got no responses...every time that i disconnect from the internet(i have dial up) My iBook kernel panics!!! specs:ibook G3 900 mhz, 640 megs of ram, airport..Again PLEASE HELP!!!!!
  2. JOD8FY macrumors 6502a


    Mar 22, 2004
    United States
    I really don't know what might be going on with your iBook. Have you tried using a different web browser? Do you have the latest software updates? Try that, but if that doesn't work and you're still under warranty, call Apple. Sorry, maybe someone else will be able to help...

  3. yoman macrumors 6502a


    Nov 11, 2003
    In the Bowels of the Cosmos
    that is odd. Have you done the normal checks?

    1)Repair Permissions
    2)Verified RAM not cause of problem
    3)used Mac Janitor

    hopefully someone has a better idea than I.
  4. yoda13 macrumors 65816


    Sep 26, 2003
    OK, I have an embarassing question. What exactly is Mac Janitor? What does it do?
  5. melchior macrumors 65816


    Nov 17, 2002
    start up using your diagnostic disk (it came with your mac) and hopefully it might come up with something.

    the other thing to do is boot into single user mode and then run fsck a few times. but don't worry about that for now. try the diagnostic disk and report back...
  6. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    Hopefully there's not a background application running that needs a net connection that isn't shutting down gracefully when the connection is cut.

    And are you running any system mods and/or the ISPs software?

    Usually those are big causes of pain for people.


    But if you are getting a lot of kernal panics, you'll need to boot up and run Disk First Aid (disk utilities) from the CD, and boot into single user mode (boot and hold command-s -- it'll boot to a text screen) and run fsck (follow directions on the screen). After that type reboot

    The kernal panics tend to cause some problems with the file system, and they'll need to be cleared up.

    Remember: both Disk First Aid and fsck need to be run until they come back with a clean pass.
  7. thejazzman10 thread starter Guest

    yes, i have done macjanitor, and the ram is apple(ughhh) there is no possible rezason that i can think of for my 'book to be doing thiss -oh and i forgot to mention, if i just remove the cord from the port&let my mac disconnect w/o noticin (the popup says "internet has disconnected)ahhh!!

    Edit: yes, i have panther
  8. sjjordan macrumors 6502

    Jun 10, 2003
    United States
    Try Fsck

    What OS are you running? If older than Panther, you might want to run fsck on your system. Reboot and hold down apple+s until you come to the prompt. run fsck -y
    It did wonders for my system.

Share This Page