Help with force quitting

Discussion in 'Mac Help/Tips' started by daedelgt, Apr 23, 2003.

  1. daedelgt macrumors member

    Jul 17, 2002
    Here's my problem. I accidentally opened iChat and it seems to have gotten stuck. No biggie I think... I open mail and it gets stuck opening my adress book, which is probably what iChat is stuck on. Still no biggie. I force quit, yet neither program force quits. I open the terminal and run top to get the process ids. Once I have those I try to kill them from the terminal. Mail goes down fine, but iChat won't budge. Kill isn't working. Now terminal has stopped working. All I do is get the beachball of death. As I am on a PB I can't just hit the reset button, as there is none, and the computer just goes to sleep when I take out the battery and unplug it. What are my other options?
  2. sparkleytone macrumors 68020


    Oct 28, 2001
    Greensboro, NC
    try the patch. ;) sorry bad joke.

    hold the power button for about 6 seconds. it will shut the PB off. Allow it 10 seconds or so, then restart.
  3. MrMacMan macrumors 604


    Jul 4, 2001
    1 Block away from NYC.
    Acually if you can get to force quit you can force quit iChat 1-2 more times. Some apps are stubborn, my QuickTime didn't want to die, it finally closed after the 3ed Force Quit...
  4. daedelgt thread starter macrumors member

    Jul 17, 2002
    Tried that after I posted, but it still didnt work. Through my magic powers I got the computer to turn off by taking out the battery again. I just had to shock it a bit ;) hehe

    Thanks though.
  5. iJon macrumors 604


    Feb 7, 2002
    i get that from time to time. i force quit and it stays. then i just force quit it again and it leaves. try force quitting 2 times in a row, then repair your permissions, then restart.

  6. calm macrumors newbie

    Apr 23, 2003
    A more unix way to do it could be to just load terminal, find the process ids through "top" or "ps", then "kill [process id]", if that does not work, try it as root, if that does not work, restart, or pull ye' old power plug...

Share This Page