Help with PowerBook's battery

Discussion in 'Macintosh Computers' started by kenkooler, Jul 19, 2004.

  1. kenkooler macrumors regular

    Jan 2, 2002
    Mexico City
    It all started when the cable near the tip near the AC adapter broke, making a short circuit between the cables there, so I removed the damaged section and united it again. It worked fine.

    About a month later, the same thing happened but it was so near the tip that I could no longer do the same, so a friend gave me a used AC adapter that no longer worked (something inside the box was destroyed by lightning, but the cable was fine) and put its tip (and part of the cable) instead of the one I had.

    Three months later, history repeats and I finally decided to buy a new AC adapter, and decided to calibrate the battery after this, so I zapped the PRAM and when the system started, the battery icon in the menu bar appeared as charging but a few minutes later, the battery icon had an X (like there wasn't any battery).

    So, now the battery won't charge at all... I don't know what's wrong since I didn't mess with anything inside the box of the AC adapter of the tip itself, and the battery was working fine with the old AC adapter. I've tried zapping the PRAM and resetting the PMU but it's not working

    I'm thinking that I'll have to buy a new battery, but do you guys have any idea of how to save the old one?

    Thanks in advance


Share This Page