Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by benpatient, Sep 13, 2004.

  1. benpatient macrumors 68000

    Nov 4, 2003
    I'm stumped...One of the other employees here in my office was having trouble getting her G5 to recognize a network printer that she had just been printing to a few moments before, and that was printing properly from other machines. I suggested that she either log out/in or restart. She did, and the printer worked at that point. But Mail wouldn't open. When i delete the mail preferences file, then it opens up just fine to the "you don't have an email address...please fill out this form" splash screen that it does when you are starting a new account on a machine.

    Well, that wouldn't be a HUGE deal, except that none of the other applications on the machine will open and actually run. Not even Disk Utility will work, so I can't check the permissions or anything. I think the problem must be Finder related. Here's generally what happens: I double click "Disk Utility" in the finder (which is actually letting me navigate like normal, I can access network folders, etc) and then the main DU screen comes up. Well, if i click on a disc image or volume (there is only one disc on this single 1.6 G5), then I get a beachball and disk utility is dead. I can force quit it, but that's all that will work. Menus are unresponsive.

    All other applications seem to be doing the same thing. Even system profiler, although it works fine for a few seconds...when i try and "quit" Profiler, then it hangs up and I have to force quit.

    What can I do short of a full erase/reinstall? Where's this legendary ease of use and "rock solid" stability? Do Unix users have to deal with this crap? I'm starting to miss windows for some terrible reason.
  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    We still get quite a few catalog/file errors -- even under OS X, it's an old file system.

    Have you tried booting from one of the CDs and running the Disk First Aid from there, and running fsck -y after booting into single user mode.

    Both of which need to be run until you get a clean pass.


    However if it turns up with no errors, it can be some third party program causing the problems. Which will mean booting into "safe mode."
  3. benpatient thread starter macrumors 68000

    Nov 4, 2003
  4. benpatient thread starter macrumors 68000

    Nov 4, 2003

    on a hunch, I tried to delete the finder preferences file. It wouldn't let me do that because I didn't "have permission" despite being the only user on the machine...and of course being admin.

    it said the file was in use. So i rebooted and went into single user mode again and deleted the file there with my rudimentary unix file system skills...which end pretty much right after 'ls' and it's variants.

    anyway, when i exited SUM, i found myself able to open all the applications that were hanging before, and Mail was working right, Disk Utility ran (which i promptly took advantage of) and everything seems peachy...

    Does every OS X application have protected memory EXCEPT the Finder? It just seems weird that this would happen. She hasn't done an unexpected reboot or anything like that...she doesn't even know the keyboard command for force quit (by design).

Share This Page