Hey Siri is answering on both Watch and phone

Discussion in 'Apple Watch' started by scriptkitten, Feb 23, 2017.

  1. scriptkitten macrumors regular

    scriptkitten

    Joined:
    Jul 11, 2007
    #1
    Every device is updated. I have a 6s and Series 2

    Anyone know why this is happening? It's super annoying and my requests are duplicated

    Is re-pairing the only fix?
     
  2. Phish311 macrumors regular

    Joined:
    Oct 29, 2007
  3. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #3
    It shouldn't so a re-pair is probably the answer.
     
  4. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #4
    My iPhone and watch do this all the time. I found that holding your watch closer to you mouth and not speaking so loud, stops it from happening.

    Do not want to turn Siri off on either of my devices as I use Siri on both.
     
  5. scriptkitten thread starter macrumors regular

    scriptkitten

    Joined:
    Jul 11, 2007
  6. abdulkar.im macrumors 65816

    abdulkar.im

    Joined:
    Feb 22, 2014
    Location:
    London
    #6
    I thought that if you twist your wrist and then say "Hey Siri!", it was meant to block the iPhone from bringing it up?
     
  7. Relentless Power macrumors P6

    Relentless Power

    Joined:
    Jul 12, 2016
    #7
    It might be inconvenient, but you can reset the Watch and set up as new. I don't if this would repair the issue, but if it's a glitch and frequently Happening less after you re-paired the Watch the first time.
     
  8. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #8
    It should do exactly that but about 1 out of 10 tried my iPhone will still answer Siri along with my AW.
     
  9. PaladinGuy macrumors 6502

    Joined:
    Sep 22, 2014
    #9
    Yes. It's pretty annoying. I wish I didn't have to do this, but I finally just turned off Hey Siri on my iPhone 7. I'd rather have both on, but it just doesn't work right that way.
     
  10. Relentless Power macrumors P6

    Relentless Power

    Joined:
    Jul 12, 2016
    #10
    Try a re-pair. Some have said it fixes the issue, others have said it partially repairs the issue.
     
  11. Sakellaris, Apr 5, 2017
    Last edited: Apr 5, 2017

    Sakellaris macrumors newbie

    Sakellaris

    Joined:
    Jul 24, 2014
    Location:
    Nea Makri Marathon Greece
    #11
    When you want to use Siri on your Watch: Put your iphone 6S in face down
     
  12. TRICKorDEVICE macrumors 6502a

    Joined:
    Sep 20, 2014
    #12
    Unfortunately Apple have just not gotten this to work correctly 100% of the time. On occasion you'll still get a duplicate response.

    It is unfortunate because I'd love to have both on all the time, but until it can cancel out one device, every time, I have to have the phone Hey Siri turned off.

    Perhaps future updates will make this work better.
     
  13. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #13
    I have said this and will repeat. Apple needs to make Siri a singularity for each user and not a collection of Siris (not sure what the plural is).
     
  14. TRICKorDEVICE macrumors 6502a

    Joined:
    Sep 20, 2014
    #14
    You're right. That needs to happen. The utility would increase exponentially.
     
  15. murdoc2k macrumors newbie

    Joined:
    Oct 23, 2009
    #15
    I also have the same issue happening to me. My phone is about 3 feet away, but super close to my  watch and when I say "Hey siri" both of them respond so OP you are not alone.

    In a live interview on WWDC 2017 Craig talked about making significant improvements on this issue, but it seems more improvements on this issue are necessary judging that many people are still affected by this.

    The only solution I can really think of at the moment without having to turn "Hey Siri" off iPhone is to press and hold the digital crown when you want to use Siri on the watch. It's not ideal as it takes away the convenience of the hands free experience, but until  solves this problem entirely, it's the only solution we have without significant trade offs.
     
  16. TRICKorDEVICE macrumors 6502a

    Joined:
    Sep 20, 2014
    #16
    These are all good points. I'm hoping iOS 11 and watchOS 4 bring significant improvements to this feature. With HomePod coming it is only going to add to the confusion if they don't get this sorted out before December.
     
  17. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #17
    Yep I already have two different Echo units that reply at the same time.
     
  18. CobraPA macrumors 6502a

    Joined:
    Mar 12, 2011
    Location:
    Lansdale, PA, USA
    #18
    As a previous poster mentioned, putting the phone face down or in a case will stop this. Siri doesn't respond when the phone is covered.
     

Share This Page