hi Why Does My Keyboard Show Accents All Of A sudden?

Discussion in 'macOS Sierra (10.12)' started by Left4DeadBoy, Feb 4, 2017.

  1. Left4DeadBoy macrumors regular

    Left4DeadBoy

    Joined:
    Sep 20, 2015
    #1
    hi So when I go to type a letter in the sense of repeating it like the e in keen I get a prompt that says whether I want to add an umlaut or any other accent to the letter I typed that was repeating; I dont want to do that and I simply want to type the letter
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    That's normal behavior if you hold the key down. Is this happening just during normal typing, or only if you hold down the key?
     
  3. Left4DeadBoy thread starter macrumors regular

    Left4DeadBoy

    Joined:
    Sep 20, 2015
    #3
    hi There anybody else bothered by this Or by that even
     
  4. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #4
    Maybe the Option key is stuck?

    What language are you using?

    What do you see if you enable Keyboard Viewer (System Preferences -> Keyboard -> Input Sources -> Show Input menu in Menu Bar, and also check the box under Keyboard -> Keyboard -> Show keyboard and emoji viewers in menu bar)?
     
  5. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #5
    This has been the expected behaviour since about OS X Lion, IIRC. So anything else would be unexpected.
     
  6. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #6
    Ohhhhhhh, I gotcha now....

    Instead of holding "h" to type "Ohhhhh", I have to press it repeatedly, right? Same with typing "aaaaaaaaa" -- I have to press it repeatedly. Holding the "a" key gives me this (see screenshot):

    This is an adaptation of the iOS way to type accented characters.

    I'm trying to find a way to disable it, but (a) I can't think of a good reason, because how many "a"s does anyone need in a row, and (b) it's nice to have the accented characters easily available.
     

    Attached Files:

  7. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #7
    I think it can be disabled with a Terminal command, but I've not tested it (and don't wish to change this feature):

    Code:
    defaults write -g ApplePressAndHoldEnabled -bool false
     
  8. Left4DeadBoy thread starter macrumors regular

    Left4DeadBoy

    Joined:
    Sep 20, 2015
    #8
    hi Hm even though you dont wish to do so could it be that you hate terminal itself By the way how does Terminal not resemble MS Dos
     
  9. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #9
    I do not hate Terminal.

    UNIX, the basis of macOS, and its command shell predate MS-DOS.
     
  10. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    Terminal resembles MS DOS, in that they both use text (and not a graphics UI), but other than that, no resemblance at all.
     
  11. BarracksSi Suspended

    BarracksSi

    Joined:
    Jul 14, 2015
    #11
    Terminal's great. You just have to know what you're doing or else you'll bork your computer.

    And as bcave098 said, it's not MS DOS.
     

Share This Page