Home Page has lightbox-like link-blocking overlay

jennyp

macrumors 6502
Original poster
Oct 27, 2007
479
69
When I come to the macrumors.com home page in Safari, and click on either the buyer's guide or forums link, the window gets a slight cast over it, like I invoked a lightbox or some similar page overlay, and from thereon I can't click on any link on the page. A page refresh appears to bring things back to normal, but then the same thing happens.

The only way I can get to the forums or buyer's guide link is to right-click on it straight away and select "Open Link in New Tab" from Safari's contextual menu.
 

theluggage

macrumors 601
Jul 29, 2011
4,752
3,606
I'm not seeing that here. Can you get a screenshot of it?
Hi, I've seen this too on the iPad - I think its being caused by the modal EU cookie policy pop-up: for some reason the dialog sometimes isn't appearing but the click-blocking translucent grey overlay is. You might have to clear your "cookie consent" cookie to reproduce.
 

theluggage

macrumors 601
Jul 29, 2011
4,752
3,606
I'm not seeing this either. I've tried on the iPad and MacBook with the updates.
I'm not seeing it now. However, it was definitely the sort of click-blocking translucent layer that you use for a modal dialog so I'd give good odds that it was the modal cookie policy dialog misfiring - and I haven't seen that again either (even after clearing browsing data) so I suspect that you'll need to trigger that somehow to reproduce the bug.

If MacRumors doesn't have a modal cookie policy dialog then something altogether more interesting is afoot...

(Also, 2004 called and wants its animated-marquee "Congratulations, you are our 1,000,000th visitor" ad back, but since I've apparently been the 1,000,000th visitor for over a week now times are obviously hard so I guess MacRumors needs the ad revenue :) )
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.