Hooking up to 1080p monitor.

Discussion in 'Mac Basics and Help' started by NinjahKitteh, Feb 6, 2012.

  1. NinjahKitteh macrumors newbie

    Joined:
    Jan 30, 2012
    #1
    I got my PC about a year ago and it came with a 27 inch monitor. I also have a early 2011, 13 inch MBP. Whenever I try to hook up the macbook pro to the 27 inch monitor, I need to underscan to have it show right. The monitor is set at 1080p and so is my macbook. The monitor seems to display my PC perfectly fine, without fiddling with underscanning or anything. So I was wondering? Any way I can fix this so I dont need to underscan? It makes my whole desktop blurry so I dont like it... Any ideas? I have already tried all the resolutions my macbook pro offered me.
     
  2. briantology macrumors 6502

    Joined:
    Jun 5, 2006
    #2
    I am not sure what you mean by "underscan", and the 13" MacBook Pro has a resolution of 1280x800 which is not 1080p. You should not have any issues connecting an external display to your Mac since it supports external displays up to 2560x1600. What kind of connection/cable are you using? Verify you are not in "mirror" mode which will most definitely limit the external display's resolution to that of your Mac's: In System Preferences go to Displays then click Arrangement. Verify "Mirror Displays" is not checked, then go back to the Display tab and make sure the highest resolution is selected.
     
  3. mandapop macrumors newbie

    Joined:
    Apr 30, 2012
    #3
    Guess what?!

    Okay, I was having the same problem... Trying to connect Macbook Pro to a 24in monitor... And I was SO disappointed I had to use the "underscanning" feature in the Displays box to make the bigger screen slightly smaller so it fit everything in there... This was horrible to me because it also made things less clear.

    BUT I FIXED THE PROBLEM!

    Go into your little settings within your ACTUAL MONITOR... And there's a section that talks about "Input"... Mine says "Input Select".. And where it mentions "HDMI", it gives an option of PC or AV... It was set to AV!! So I set it to PC and life became wonderful again! :) Spread the word. This seems to be a common problem but not everyone realizes it's the monitor.
     
  4. wyatt268 macrumors newbie

    Joined:
    Oct 21, 2016
    #4
    Thanks mandapop!

    My monitor problem was similar to yours except I had to go into Image Control -> Auto Resizing -> Overscan -> OFF. Apparently is was on which was what was giving me the same problem.
     
  5. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #5
    Ninja -

    What's happening is that the Mac is "seeing" the display as if it is a "tv", and NOT a "computer monitor".

    And, the Displays preference pane is offering you [what it thinks to be] your best options, insofar as controlling the monitor is concerned.

    How to tell if your computer sees the display "as a display", or if it sees the display "as a tv":
    1. Go to the displays pref pane in system preferences.
    2. Click "display", and then click the "scaled" radio button, and observe the choices
    3. IF you see ONLY resolution "numbers" (such as "1920x1080"), the Mac is seeing the display as a computer monitor.
    4. IF you see resolution sizes stated as "1080p", etc., the Mac is seeing the display "as a tv", instead of as a computer monitor.

    Sometimes, how the Mac sees the display depends on what connection method you have between the Mac and the display.
    An "HDMI" connection (at both ends) may be much more likely to result in the Mac seeing the display as a tv.
    A "minidisplayport to displayport" connection (Mac to monitor) is more likely to have the Mac see the display as a computer monitor.

    There's a method that FORCES the Mac to see a display "as a computer monitor", but it's a little involved.
    It -CAN- be done (I've done it on mine).
    Here are instructions on how to do it:
    http://www.mathewinkson.com/2013/03...ix-the-picture-quality-of-an-external-monitor
     

Share This Page