Host files Edited: but still get "This device isn’t eligible for the requested build"

Discussion in 'iPhone' started by AndrewJay, Aug 22, 2012.

  1. AndrewJay macrumors newbie

    Joined:
    Mar 2, 2009
    #1
    So as the title says, but a bit of background first.

    MY iPhone 4 is jail broken on 4.2.1 and has been for ages, i never unlocked it via jail brake, but recently o2 unlocked it for me.

    Now i would like to upgrade to 5.1.1 jail broken or not jail broken, i dont mind about the baseband as O2 have unlocked my phone and tbh im more that happy to have this entire iphone put back to "factory settings" on iOS5 it that makes sense.

    Ideally i'd love to have jail broken 5.1.1 but at this point i more than happy to do whatever is easiest.

    My iPhone currently works fine normally no issues but when i try to upgrade i get "This device isn’t eligible for the requested build" i put it in DFU and try to restore but still same issue, i have editied the Host flie still same issue, itunes is up to date and i've tried it on a PC thats never had any iphones on it or even itunes and i get error 3194.

    The only thing i havent tried is Update button via itunes but im reluctant to do this as i know previous if you use this on a jail broken model it can brick it.

    What i'd like if any one knows is a nice step by step on how to fix this, bearing in mind that i have tried the host file, and tried that tinyumbrella option about connecting to cydia but that is grey out, but liek i say i would just like 5.1.1 on my iphone in any form jailbroken or not


    Please please Help


    Thanks Andrew
     
  2. DerekRod macrumors 6502a

    DerekRod

    Joined:
    Jan 18, 2012
    Location:
    NY
    #2
    You can update via iTunes update button your unlocked you dont need to preserve baseband obviously and no it wont brick your phone,whomever said that is wrong
     
  3. AndrewJay thread starter macrumors newbie

    Joined:
    Mar 2, 2009
    #3
    Thanks my mate helped me out :)

    last time i was messing with this jail break stuff you could brick your iphone.

    updated thru itunes to 5.1.1 and then jailbroke the phone with pwnage tool 5.1.1 all sorted fine no issue :)
     

Share This Page