How can I get my iPhone 3GS to recognize my AT&T SIM card after upgrade to iOS 5.1?

Discussion in 'iOS 5 and earlier' started by AdinaLeba, Apr 2, 2012.

  1. AdinaLeba, Apr 2, 2012
    Last edited: Apr 2, 2012

    AdinaLeba macrumors newbie

    Apr 2, 2012
    I upgraded my previously-unlocked iPhone 3GS to iOS 5.1 today, from iOS 4. I hadn't upgraded the OS in awhile (since the phone was unlocked before a trip overseas).

    iTunes says: "There is no SIM card installed in the iPhone you are attempting to activate. Please disconnect and insert a SIM card in the iPhone." I tried taking out and reinserting the SIM card, but that didn't help. It seems that I cannot restore to factory settings now, since iTunes doesn't think my phone has a SIM card and so won't connect to my phone at all.

    I realize now that I should have restored to factory settings before upgrading, but given that I did not, how can I fix this retroactively?


  2. macbook pro i5 macrumors 65816

    macbook pro i5

    May 13, 2011
    New Zealand
    Put it it in DFU(device firmware update) mode here is how:
    1)Turn the phone off
    2)Press and hold the home/wake and sleep/power on button for 10 seconds
    3)After the ten seconds let go of the power button and continue holding home button for a further 10 seconds.
    Now iTunes will inform you that it has discovered an iPhone in recovery mode,Go to the iphone tab and it should give an option to restore the iPhone press that,after that let it do its thing:) now if you require additional assistance for DFU mode go to this link:
  3. Holoshed macrumors regular

    Mar 24, 2011
    North Carolina
    Just to cover for information sake, are you sure it was hardware unlocked and not software unlocked? I know it's rejecting your AT&T sim which means over seas bought but I could still have been a software unlock which would make it not work when new iOS installed.

    If it is hardware unlocked for sure then go into settings and reset is in there somewhere. Can try to do a full reset and let it try to activate connected to iTunes.
  4. theromulus macrumors newbie

    Apr 9, 2004
    Having the same problem with my 3gs. AT&T unlocked my iPhone which I previously had unlocked with redsn0w. I plugged it in and got the phone unlocked message and everything worked fine. Then I decided to upgrade to 5.1 since it was unlocked. Now I keep getting the message that there is no SIM card installed in the phone you are attempting to activate. I have restored a few times deactivated with redsn0w and SAM and still getting this message with the at&t sim as well as a couple of different tmobile sims. Any advice? I tried the restore from dfu as was mentioned in one of the replies as well, still no good.
  5. lelisa13p macrumors 68000


    Mar 6, 2009
    Atlanta, GA USA
    Have either of you tried calling AT&T, since they were the source of your unlock?

Share This Page