How can I install the old version of IOMEGA (2.1) on my Mac

Discussion in 'macOS' started by peacefulpat, Jan 22, 2011.

  1. peacefulpat macrumors newbie

    Joined:
    Jan 22, 2011
    #1
    I just bought Mac OS X, and I tried to install IOMEGA 2.1 which I bought long time ago. It said I cannot install because of no classic support. What should I do? Thanks.
     
  2. peacefulpat thread starter macrumors newbie

    Joined:
    Jan 22, 2011
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    What is Iomega 2.1?
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    I assume that you are talking about Iomega Hotburn 2.1.7. This latest version of the software dates back to 2003. However, it is much older than that. Hotburn is Classic software. Intel-based Macs cannot run Classic software. If they could, then this software would be unnecessary. Its functionality is built into MacOS X.
     

Share This Page