How do I get good quality uploading an iMovie video onto YouTube?

Discussion in 'Mac Apps and Mac App Store' started by MK25toLife, Jan 27, 2009.

  1. MK25toLife macrumors regular

    Joined:
    Aug 7, 2007
    #1
    I have tried uploading directly from iMovie to YouTube using the preset and it looks absolutely horrendous. I have also tried exporting into NTSC quality and the "large" preset and they both still look terrible.

    The video I am using is imported DV from a Sony Handycam, it's not that great of camcorder but when I watched the videos on my TV it looked fine. It's real simple video too, just video of my friend talking. What is the root of this problem and how can I fix it?
     
  2. Mx356 macrumors member

    Mx356

    Joined:
    Oct 13, 2008
    #2
    I found these settings to be the best for me:

    Compression: H.264
    Frame Rate: Current FPS
    Key Frames: Every 24 Frames
    Data Rate: Restrict to atleast 2,000 ... I usually do around 6,000
    Quality: High
    Encoding: Best Quality
    Size: HD 1280x720 16:9

    Try that and see what that works. Its going to be longer export times and longer upload times but its worth it.

    Here's a video I uploaded with those settings:

    http://www.youtube.com/watch?v=gqwDLvnacS0
     
  3. MK25toLife thread starter macrumors regular

    Joined:
    Aug 7, 2007
  4. macmommainks macrumors newbie

    Joined:
    Aug 3, 2008
    #4
    wow that example looks awful!! LOL! He was wanting good quality!
     
  5. vohdoun macrumors 65816

    vohdoun

    Joined:
    Jan 23, 2006
    Location:
    Far away from Earth.
    #5
    ..........

    I hope that was sarcasm.
     
  6. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #6
    Why on earth are you exporting at 720p for a YouTube video?

    EDIT: Didn't realise YouTube had HD options now..

    Still, the original YouTube (non HD) quality is pretty dreadful though.
     
  7. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #7
    I second these settings.

    Maybe you should try clicking "Watch in HD."
     

Share This Page