How do I get my phone number at the top of my contacts list?

Discussion in 'iPhone' started by TheSpaz, Oct 1, 2008.

  1. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #1
    Okay, so on my First Generation iPhone, my phone number was conveniently listed at the top of the contacts list (above the search field). Now that I have an iPhone 3G, it's no longer there. How can I get this feature back? Also, I synced the SAME contacts with my 3G that I had on my original iPhone. Also, myself is listed in my contacts with my iPhone's phone number as my phone number, but it still won't display it above the contacts list.

    My question is... do you have it? Do you know how I can get it back?
     
  2. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #2
    Yeah I have it above the search option.

    iPhone 3G running 2.1.
     
  3. fireshot91 macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
  4. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
  5. fireshot91 macrumors 601

    fireshot91

    Joined:
    Jul 31, 2008
    Location:
    Northern VA
    #5
    Are you guys that don't have it going through the contacts app, or through the phone app then going to the contacts tab?

    maybe it matters?

    EDIT: I just checked my Contacts app and I don't have my phone number up there. on the Phone app I do. so it DOES matter.
     
  6. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #6
    Doesn't show up for me in either Phone > Contacts or Contacts app
     
  7. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #7
    I believe it is tied to the sim card? I might be wrong on that but I remember a thread about this a while ago. So if you swapped the sim card it might not show?.?
     
  8. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #8
    Oh, it must have something to do with the SIM. When I upgraded my iPhone to a 3G, they replaced the SIM card with a new one in the 3G. I bet that one doesn't have my number correctly embedded in it. Hmm.
     
  9. kleo macrumors regular

    Joined:
    Feb 18, 2008
    #9
    Its there on mine. All the way at the top above the search field.
     
  10. gvincent macrumors newbie

    gvincent

    Joined:
    Oct 1, 2008
    Location:
    Hoover, AL
    #10
    contacts

    I just put an "a" in front of my name and it placed me at the top of the list, works for me!
     
  11. rarity macrumors regular

    rarity

    Joined:
    Sep 27, 2008
    Location:
    Florida
    #11
    Mine's there if I go through the phone, then contacts.

    It's not there if I go directly to the contacts icon. HTH.
     
  12. rarity macrumors regular

    rarity

    Joined:
    Sep 27, 2008
    Location:
    Florida
    #12

    I think the OP means the phone automatically displays his telephone number in All Contacts, not by adding yourself as a contact.
     
  13. ttech10 macrumors 6502

    Joined:
    May 16, 2008
    #13
    Mine's always there on the 3G and was always there on the 2G.
     
  14. Streamer macrumors member

    Joined:
    Apr 18, 2008
    #14
    Likewise, brand new iphone, new sim and new AT&T account.
     
  15. joe8232 macrumors regular

    Joined:
    Jun 21, 2005
    #15
    All you have to do is take the sim out and pop it in a phone that has the my number option in the phone book [most nokia's do], then simply write in your number and it gets saved to the sim card and will show up at the top when you put it back in your iphone.
     
  16. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #16
    Okay, it appears in the Phone contacts App but, not in the plain contacts app.
     
  17. bigscotal macrumors 6502

    bigscotal

    Joined:
    Jun 26, 2008
    Location:
    UK
    #17
    +1

    Not actually tried this myself yet, but I have read the same answer to this dilemma in several places now.
     
  18. Stepper macrumors regular

    Joined:
    Oct 2, 2008
    Location:
    North London, England
    #18
    I was wondering this to. It was there on my 2g iPhone, recently upgraded and its not there....oh well i know my number anyway :cool:
     
  19. bluenoise macrumors 6502a

    Joined:
    Jul 16, 2008
    #19
    This has been answered before. Even this thread had this answer several posts up.

    Edit: I'm sorry for jumping the gun on this one. I just rechecked mine and it's not showing in either version of my contacts. It used to show only when I viewed my contacts from the phone app, but it isn't now.
     
  20. TheSpaz thread starter macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #20
    Oh, what if I don't have another phone?
     
  21. bluenoise macrumors 6502a

    Joined:
    Jul 16, 2008
    #21
    I'm going to try it in my wife's phone or my kids' phone. Maybe a friend will let you try it in their phone. It shouldn't take long.
     
  22. slicecom macrumors 68020

    Joined:
    Aug 29, 2003
    Location:
    Toronto, Canada
    #22
    Mine shows only at the top of the Phone Contacts app, but not the Contacts app.
     
  23. jimmy83 macrumors 65816

    Joined:
    Aug 21, 2008
    Location:
    Portsmouth, UK
    #23
    If I go to my iPhones home screen then select phone, contacts above search my number isn't there. How else can you view your contacts?
     
  24. grimreaper1377 macrumors regular

    Joined:
    Oct 20, 2007
    #24
    I think it's because of your sim card. Mine wasn't there on the old iPhone (2g) but its there on my 3g.
     
  25. upsguy27 macrumors 65816

    upsguy27

    Joined:
    Jun 25, 2007
    Location:
    Arizona
    #25
    You should have a contacts app on your home screen.
     

Share This Page