How do I reduce the number of emails Mail stores? Right now I have 13,000...

Discussion in 'Mac Apps and Mac App Store' started by oregon2, Oct 24, 2010.

  1. oregon2 macrumors regular

    Joined:
    Jul 7, 2009
    #1
    Currently I have Mail configured to save every email and I can't work out how to change it. Anyone know?
     
  2. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #2
    Create a rule that deletes things that are older then X days.
     
  3. oregon2 thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #3
    how do you do this? and will it delete mail from the server as well?
     
  4. Turian.Spectre macrumors regular

    Turian.Spectre

    Joined:
    Aug 31, 2010
    #4
    step 1, 2, 3. in screenshots =) It should delete them from your server if your account is set up that way in mail. When you press "delete" on a message, does it erase from your server as well? If it does, this should also do it. Oh and make sure to specify how many days YOU want. personally I dont have such a rule. Maybe in the future I will make one to delete things that are 4-5 years old. the example I showed you is 365 days - 1 year.
     

    Attached Files:

  5. oregon2 thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #5
    okay that looks like it will work, HOWEVER, I want my gmail to save all my email. unfortunately right now I have it set up that when I delete an email in Apple mail it also deletes it in gmail.

    do you know how to change it so that gmail still saves everything?
     
  6. iKennett macrumors 6502

    Joined:
    Nov 22, 2007
    #6
    Also interested in this however if 'space' is your prime concern you can tell mail to only keep the message and not download attachments for offline viewing if that helps..... via advance tab in account settings.
     
  7. Turian.Spectre macrumors regular

    Turian.Spectre

    Joined:
    Aug 31, 2010
    #7
    At this point I am starting to guess. I think if you use POP instead of IMAP you could do that. Change your setting in your gmail from a browser, and also make sure your Mail app account server settings also match.
     

    Attached Files:

    • 4.PNG
      4.PNG
      File size:
      141 KB
      Views:
      91
  8. ShinyDren macrumors member

    ShinyDren

    Joined:
    Jun 25, 2010
    Location:
    Ambitoysterous, USA
    #8
    For one of my IMAP accounts I have the settings shown in the picture. Specifically - "Store deleted messages on the server"

    From the help screen for Mail:
    "Store deleted messages on the server

    Specify whether to store messages you delete on the mail server, so they’re available if you use your account from a different computer.
    This option is available only for IMAP and Exchange 2007 accounts."

    This leaves the messages on the server after I delete them on my computer.
    Hope this helps some.

    Disclaimer: I am not using this with a gmail account so I can not guarantee this will work the same for you.
    Do NOT use with gmail! See post below.
     

    Attached Files:

  9. Turian.Spectre macrumors regular

    Turian.Spectre

    Joined:
    Aug 31, 2010
    #9
    DO NOT FOLLOW THESE INSTRUCTIONS. Gmail settings, specifically say you should NOT use this option.
     
  10. ShinyDren macrumors member

    ShinyDren

    Joined:
    Jun 25, 2010
    Location:
    Ambitoysterous, USA
    #10
    Possible solution

    After checking I see that Turian is correct.
    Maybe some people would appreciate knowing exactly what settings google recommends, and why. So here is the link to that info:
    http://mail.google.com/support/bin/answer.py?answer=78892

    Click on the Apple Mail link on that page and use those settings. The explanations at the bottom of the page tell you basically what happens.

    But there is hope.

    Here is a solution that worked in my limited testing (but I do not have anywhere near 13000 messages in my gmail account). :D

    1. Set up Mail with the recommended settings.

    2. Login to gmail from your browser.

    3. Click on "Settings" at the top right of the window.

    4. Click on "Labs". (Hopefully this is available for you, it is not on the screenshot from Turian, but is is for me.)

    5. Read the info at the top of the screen, then find "Advanced IMAP Controls" and click "Enable". Make sure you also click the "Save Changes" button. (See screenshot)

    6. Click on "Labels".

    7. Remove the "Show in IMAP" check mark for "All Mail". Remove the check marks for all other labels you are using unless you want those messages to be on your computer. (See screenshot)

    8. If Mail is still running you may need to quit and relaunch it before the changes are made. (Might take a little extra time the first launch as it decides what should and should not be on your computer.)

    Now you only have a limited number of messages on your computer and all of them are still on the server. Bobs your uncle. :D
     

    Attached Files:

Share This Page