How do I stop stop the annoying email notification sound in Safari

Discussion in 'Mac Basics and Help' started by kmdonovan1, Nov 22, 2013.

  1. kmdonovan1 macrumors newbie

    Joined:
    Nov 22, 2013
    #1
    This is my first post to this group. Hello all and thanks for the help in advance.
    I have searched the forum and have not found a similar thread so if there is one I apologize.
    Just a small but annoying thing I can't seem to fix. Since up grading to Mavericks when I open Safari I get an annoying bell chime letting me know that I have email waiting. I have gone through the system preferences and the Safari preferences but cannot seem to turn this off.
    Any help would be appreciated.
    -Thanks
     
  2. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #2
    Seems to me more likely that its gmail or hotmail or some other web based email you have as a default on your Safari opening page thats doing that ?

    Safari itself surely has nothing to do with email ?
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #3
    It's possible that a Safari "local notification" is occurring.

    The sounds associated with notifications are controlled here:
    System Preferences > Notifications pane > Safari item in list

    On Mountain Lion there is a checkbox that enables/disables sounds.


    The actual sending of local notifications is done by JavaScript in a web-page. See these references for technical details:
    https://developer.apple.com/library...es/LocalNotifications/LocalNotifications.html
    https://developer.apple.com/notifications/safari-push-notifications/


    It might help diagnose the cause if the OP identified which email service he's using. By this I mean something like Yahoo mail, Gmail, Hotmail, etc. More specifically, exactly which webpage is being visited to check email.
     
  4. kmdonovan1 thread starter macrumors newbie

    Joined:
    Nov 22, 2013
    #4
    Tried Notification

    I did check notifications in the systems panel and turned off the notification sound for Safari a few days ago. I also checked my Gmail preferences and there is no notification sound preference and it only started happening when I updated to Mavericks a couple of weeks ago. It also only happens in Safari. When I open FF or Chrome it does not make an alert sound.

    Stumped on this end...

    Thanks for your help.
     
  5. HattoriH macrumors newbie

    Joined:
    Mar 18, 2014
    #5
    Same same - did you find any solution

    Same thing over here. For sure it does not have anything to do with mail, since it happens disconnected from any incoming mail.

    Notification setting for safari is turned off.

    Is there any other sound / notification option hidden somewhere in safari?

    Many thanks!
     

Share This Page