How do you Unistall Net Barrier??

Discussion in 'Mac Help/Tips' started by coopdog, Dec 23, 2002.

  1. coopdog macrumors 6502a

    Oct 5, 2002
    The Great Midwest
    I installed Net Barrier X in Jag, a window popped up saying there is a problem running Net Barrier do you want to "Fix and Use" and 2 other choices. I clicked the "Fix and Use." I went to the share panel and the Os X built in firewall does not work because the net barrier extension is running. So I searched for all the files containing barrier and deleted all of them. There were 3 that I couldn't delete because they were in use. I tried seeing in process viewer if any of the items in use were a process or if there was a net barrier process, No. I tried logging in as root in net info. I still can't delete them. So what I'm asking is, does anyone know how to uninstall Net Barrier and get the OS X firewall to work? Thanks A lot!
  2. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    You should be able to delete the Intego folder under Library, which is not the same as System/Library. The daemon lives there.

    If you cannot do this as your default administrator, log out via the Apple menu and log in as root, then go to the folder and delete it.

    If the files are in use, use Process Viewer and look for integod and kill it. Then, try to delete the files again.

    I'm still not sure why you would install NetBarrier and then try to also use the built-in firewall. That only sounds like trouble to me.

Share This Page