How here's a rat's nest! 1st Gen, 2.2.1 Only in Emergency mode w/ SIM

Discussion in 'Jailbreaks and iOS Hacks' started by Bralmick, Jun 7, 2009.

  1. Bralmick macrumors newbie

    Joined:
    Jun 7, 2009
    #1
    Dear all,

    First of all, thanks for checking out my post here. I really appreciate the helpful attitude of the people on this forum, you all rock!

    So here's what I got.

    I have an iPhone 1st Generation, Firmware version 2.2.1. After some research I found my best solution to unlock it form AT&T to use on T-Mobile was to go ahead and use QuickPWN.

    I downloaded the necessary files and went through with it. I now have Cydia and the Installer on my phone, everything went just fine, didn't brick it as far as I can tell.

    Now I have an old AT&T SIM card and the one I want to use, my T-Mobile SIM card.

    When I install the AT&T Card or without a card, everything works fine, I can't make any calls or search the web without an internet connection (due to my using an old AT&T SIM which is from an old account with AT&T) it basically now acts like an iPod Touch.

    Now, when I put in my T-Mobile sim I immediately get the notice:

    Different SIM detected
    Please connect to iTunes ​


    Here's the funny part, if I slide over for an emergency call, I can see full bars with T-Mobile! I can call anyone, but I just can't access anything else besides this Emergency Call thing.

    Even if I dial in, for instance my wife's phone number it brings up her beautiful face in the background while making the call!

    But I can't get past this screen with my T-mobile SIM card in.

    Now one issue may be that the T-Mobile SIM is old, it's one I've had since I used my Sidekick back in the day, so it's about 5 years old.

    But if that were the issue, I shouldn't be able to make phone calls with it, right? I can make calls clear as day, can't access my phone book or anything like my home screen (just dial them in from the Emergency screen), but I can make phone calls!

    Oh, and just so it's known, I don't think it's "bricked" because as soon as I take the SIM card out, it works just fine in "iPod Touch Mode" (No Network, no phone calls no SMS, just music, browser when I have wifi, etc)

    I tried searching for this exact problem and couldn't find that anyone else had it.

    Do you think you can help me out?
     
  2. Ratpack1961 macrumors member

    Joined:
    Apr 7, 2006
    #2
    You need to install the bootloaders that allow the iphone to make calls

    1. Download Pwnage Tool

    2. Download the bootloaders, most likely BL-3.9

    3. Place the bootloaders in the same directory as pwnage tool.

    4. Make sure you have 2.2.1 firmware downloaded on your computer and in the pwnage tool directory. Make sure the filetype ends in .ipsw

    Run Pwnage tool, it will then create a customer 2.2.1 firmware with the bootloaders included.

    5. Open Itunes and press the option button when you click restore. You can then browse for the custom firmware you just created. Select it and Itunes will install the custom firmware that will let you use the phone features.
     
  3. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009
    #3
    As I show above, my understanding of your response, which is much appreciated by the way, is based on the use of QuickPWN if you are speaking of a completely seperate one then let me know.


    Just so the objective is in mind here, all I really want to do is be able to unlock the phone and use EDGE for my internet as I can on my regular t-mobile phone. I'm not all that interested in uploading many different programs on my phone at this time and thus "jailbreaking" meaning being able to get APs from elsewhere and such is really not a necessity for me.
     
  4. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #4
    If you are on a mac you should press the option key when restoring for it to ask you for a file or on windows press the shift key.
     
  5. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #5
    I believe your problem is caused because the QuickPwn unlock fails when the phone is already activated to a legit carrier. I had the same problem.

    The way I solved it was to put the phone into DFU mode and connect to iTunes, letting it restore to the latest version. I then did NOT activate it with iTunes, but ran the QuickPwn process, and the unlock worked fine that time.
     
  6. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009
    #6
    Probably would be easier if I was.
    No, I'm on a Vista.

    I can receive texts as well if I view them from the lock screen, found that out today, but can't respond to them because can't get past the Emergency dial screen.

    & if it helps, I do get Edge, I can see the "E" in the top bar where my connection status & the T-Mobile service is shown (as opposed to "3G" & AT&T Service).

    So if I can just get past this emergency screen for good, I bet I'm home free!
     
  7. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #7
    See my post above, posted at same time as yours.
     
  8. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009
    #8
    Wow perfect! I can try that tonight, it has been activated, that's true.

    But how exactly do I put the phone into DFU mode & restore to latest version? & how do I know when I have DFU mode?
     
  9. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009
    #9
    I figured this out by searching it. I held down the home and power for 7 seconds and then held the home button until it asked if I wanted to update on my iTunes screen.

    I'm not downloading the iPhone Software Update from iTunes for the phone, it'll take about 4 hours from what I can tell.

    Now you also mentioned activation. Don't activate it with iTunes? Will it be obvious when I get to that step and at this point am I following the procedure correctly or should I be doing something else to restore my phone?

    Right now the phone's screen is black and doesn't come up at all, since I held the power+home button for 7 seconds and then continued to hold the home button for another 20 seconds. I was prompted by iTunes to check for a restore and am now downloading it into my Downloads file. So far so good? I have 4 hours until it's done downloading.
     
  10. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #10
    Yes, I think iTunes will ask you to activate the phone when it's all done. Don't accept, instead, go on to use QuickPwn again.

    Good luck :)
     
  11. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009
    #11
    It works!

    Now how do I get the browser up and working? I get this message, Moi,

    Could not activate cellular data network: You are not subscribed to a cellular data service.
     
  12. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009
    #12
    Set the General > Network > Cellularl Data Network to epc.tmobile.com

    But now I dont get the above message, I get a page that come up as 10.14.76.174/dsb/t-mobile... etc.

    And it looks like some kinda script page. Just black text on white.

    Look slike I can't use a google search engine, I can search but I only get select sites. For instance Yahoo or something.

    Maybe I just need to reset the Cell Data Network settings to another code specific to t-mobile?
     
  13. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #13
    Maybe it would be best now to post a new question on how to access the t-mobile cellular data network. There are lots of people on the forum have done that OK but they probably won't be reading this thread. Good luck.
     
  14. Bralmick thread starter macrumors newbie

    Joined:
    Jun 7, 2009

Share This Page