How the heck do you disable the history in Safari?

Discussion in 'Mac Apps and Mac App Store' started by Jigglelicious, Jun 7, 2004.

  1. Jigglelicious macrumors 6502


    Apr 25, 2004
    I gave my parents my old iMac to use so they can start browsing the web. However, every time they start to type in a web address and safari butts in with its autocomplete history, it confuses the heck out of them and they don't know what to do. So basically I want to completely disable Safari's history, or at the very least, its autocomplete feature. I've looked everywhere and can't find the option for this. Could anyone assist?
  2. spav macrumors newbie

    Apr 22, 2003
    Cleveland, OH
    Safari autocompletes any bookmarks you have also. They may be autocompleting from there.
  3. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway
    With Mozilla you can turn off autocompletion in the preferences: Goto Navigator -> Smart Browsing and uncheck the Location Bar Autocomplete and you will only get what you type.

    Maybe your parents could use Mozilla until Safari gets this feature (which Apple ought to add as soon as possible).

    Good Luck.
  4. Frisco macrumors 68020

    Sep 24, 2002
    Okay you can disable the History from Autocompleting, but I don't know of any way to prevent it from automcompleting from your booksmarks.

    Here's how
    (1) In Safari go to History>Clear History
    (2) Close Safari
    (3) Go to Home>Library>Safari
    (4) Get Info on the File History.plist
    a) Change Ownerships & Permissions to Read Only
    b) Check the locked tab on top
    c) Click on the little lock icon on the bottom

    Safari stills remembers the history until you close Safari

    I wish I knew of a way to stop autocompleting from bookmarks

    Safari's autocompletion is its worst feature
  5. Jigglelicious thread starter macrumors 6502


    Apr 25, 2004
    Thanks a ton. Its not as simple as it should be, but it does the job well enough. My main issue is with Safari and its autocomplete - instead of autocompleting only the root website (ex-, it'll autocomplete the longest possible list of directories into the site (ex-, which is of no help at all.
  6. hermitizer macrumors newbie

    Jun 17, 2003

    try downloading and installing of the options is to set the number of sites to store in your history...setting to 0 should eliminate your problem...
  7. parrothead macrumors 6502a


    Sep 24, 2003
    Edmonds, WA
    Hmmm, I wonder what you are trying to hide from your parents?? :D ;)
  8. Macooter macrumors newbie

    Feb 10, 2009
    solution - foolproof method

    For previous visits to Go to Macintosh HD, Username, Library, Safari, History.plist. Open that file. Manually delete all the code and such. Close file, and choose save, then overwrite. That will put a stop to all autocomplete url in the safari browser. Of course you need to set your normal autocomplete business to off in your general preferences in safari.

    You can also delete the downloads.plist in the same way.

    One more detail. This does not remove autocomplete for urls in your bookmarks. You have to delete the bookmark if you want that to stop remembering where you have gone online.

    After doing all that, choose safari, reset safari, and you should have no more problems.

    And finally: be good online, and you won't have to go through all those annoying steps.
  9. ihabime macrumors 6502

    Jan 12, 2005
    Wow, just wow. I know you're new, but you just dredged up a thread that's been dead for 5 years, that's the oldest thread I've seen someone do that to. They were probably talking about safari 1.03 :p

    And I think your hint is wrong, there's no preference for turning off address bar completion, just webpage form filling.
  10. Sayer macrumors 6502a


    Jan 4, 2002
    Austin, TX
    I find the Autocomplete works better than Firefox. Firefox 3's autocomplete is so horrendous its almost unusable as it tries to match *anything* you type to *any* part of a URI including the website's name for pete's sake.

    Also, Safari automatically bubbles up more frequently typed in URLs to the top of the list over time.

    You couldn't just tell your parents to ignore the list?

Share This Page