How to bypass you have downloaded this from the internet are you sure you want to ope

Discussion in 'macOS' started by bahamallama, Jun 13, 2009.

  1. bahamallama macrumors member

    bahamallama

    Joined:
    Jun 28, 2008
    #1
    I am trying to setup a wordpress install with MAMP.
    MAMP goes on fine. I extract Wordpress and move it to a folder called blog in the correct mamp directory.
    When I go to localhost:8889/blog/
    it displays nothing. It's a working directory as I don't get an error so I think the problem is the "you downloaded this do you want to open it" dialogue since I get this everytime I try to edit one of the files as I had to to setup the wp-config.php settings.
    Instead of manually clicking on every file in the wordpress directory is there a way to just bypass that prompt all together just for this directory?
    I'm using leopard and a macbook pro. It's a local install so I can get my theme and phpbb3 bridge setup done before uploading to my webserver.
    Thanks in advance!

    d
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    That prompt isn't the issue. I've done the same thing as you and didn't have the issues. I would find your PHP error log and see if there are any messages as it's the most likely culprit.
     
  3. bahamallama thread starter macrumors member

    bahamallama

    Joined:
    Jun 28, 2008
    #3
    Here's the error code:
    [14-Jun-2009 12:36:47] PHP Parse error: syntax error, unexpected T_STRING in /Applications/MAMP/htdocs/FFMD/wp-config.php on line 21

    Here's the code from the page:
    Code:
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'FFMDWordpress');
    /** MySQL database username */
    define('DB_USER', 'root');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'root');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost:8888');
    
    
    Line 21 is the define('DB_USER', ) line. That is the user.

    I have tried it without the single quotes as well with the same error.
    To me it's looks correct and is what the tutorial told me to put in and what the mamp page told me as well. I'm guessing I'm missing a character or something in there?

    Thanks!

    d
     
  4. bahamallama thread starter macrumors member

    bahamallama

    Joined:
    Jun 28, 2008
    #4
    Solved.

    ID10t error!

    Textmate had saved the wpconfig file to the root directory instead of under FFMD and so when I kept making changes it wasn't seeing them since it wasn't in the correct area.

    Thanks for everyone who looked and for angelwatt for helping me to see my mistake!

    d
     

Share This Page