How to create a USB Installer for the 2018 MBP

Pati3883

macrumors newbie
Apr 30, 2019
1
0
Hi Guys,

I have problem with creating USB installation for High Sierra.
I downloaded installation disc from the direction which was provided at the first post.

It appears in the section: Download on my mac pro early 2011. (I attached you screen)
I have copied the script and paste in to the Terminal which I have updated with the name of my USB and also the name of the Instalation disc.
What I received is: that command not found (attached screen)

sudo /Volumes/Install_macOS_10.13.6-17G65/Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume

I don't know if I did something wrong or something is not correct. I have clean my USB and formatting it to the right format: Mac OS Extended.

Maybe somebody will help new person in the Mac world :D

Thx.
 

Attachments

mathewgx

macrumors newbie
Jul 27, 2016
19
3
Im getting this list :


2 091-95155 10.13.6 17G66 2019-01-08 macOS High Sierra

3 091-94326 10.13.6 17G65 2018-07-11 macOS High Sierra

5 091-95774 10.13.6 17G2208 2018-07-30 macOS High Sierra


Which one is the best choice for my MBP 2018 ?
 

chrfr

macrumors G3
Jul 11, 2009
8,584
2,767
Im getting this list :


2 091-95155 10.13.6 17G66 2019-01-08 macOS High Sierra

3 091-94326 10.13.6 17G65 2018-07-11 macOS High Sierra

5 091-95774 10.13.6 17G2208 2018-07-30 macOS High Sierra


Which one is the best choice for my MBP 2018 ?
Only 17G2208 will install on the 2018 MBP.
 

mathewgx

macrumors newbie
Jul 27, 2016
19
3
Thank you.

Can I ask an off topic question ?
My brothers macbookair late 2018 (smbios 8,1) came with Mojave installed.
Is there any compatible HS version that he could downgrade to?
 

chrfr

macrumors G3
Jul 11, 2009
8,584
2,767
Thank you.

Can I ask an off topic question ?
My brothers macbookair late 2018 (smbios 8,1) came with Mojave installed.
Is there any compatible HS version that he could downgrade to?
No, the Air is only compatible with Mojave.
 

Ploki

macrumors 601
Jan 21, 2008
4,089
1,351
will the 17G66 install on a 2018 mbp? i want to downgrade.

i dont get 2208 on the list. Will it work if i get it elsewhere?
 
Last edited:

chrfr

macrumors G3
Jul 11, 2009
8,584
2,767
will the 17G66 install on a 2018 mbp? i want to downgrade.

i dont get 2208 on the list. Will it work if i get it elsewhere?
17G66 will not run or install on a 2018 MBP.
To get 17G2208, you need to specify the High Sierra catalog, so run this:
Code:
installinstallmacos.py --catalogurl https://swscan.apple.com/content/catalogs/others/index-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog
This should give you the following options:
Code:
1    091-95155    10.13.6    17G66  2019-01-08  macOS High Sierra
2    091-94326    10.13.6    17G65  2018-07-11  macOS High Sierra
3    041-69971    10.14.5  18F2058  2019-07-09  macOS Mojave
4    041-47723    10.14.4  18E2034  2019-03-25  macOS Mojave
5    041-59913    10.14.5   18F132  2019-05-13  macOS Mojave
6    041-73257    10.14.5  18F2059  2019-07-31  macOS Mojave
7    091-95774    10.13.6  17G2208  2018-07-30  macOS High Sierra
8    041-88929    10.14.6    18G84  2019-07-22  macOS Mojave
Also, don't forget that you have to run this script on the 2018 MBP, or on a virtual machine, in order to make the 17G2208 installer.
 
  • Like
Reactions: Ploki

Ploki

macrumors 601
Jan 21, 2008
4,089
1,351
17G66 will not run or install on a 2018 MBP.
To get 17G2208, you need to specify the High Sierra catalog, so run this:
Code:
installinstallmacos.py --catalogurl https://swscan.apple.com/content/catalogs/others/index-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog
This should give you the following options:
Code:
1    091-95155    10.13.6    17G66  2019-01-08  macOS High Sierra
2    091-94326    10.13.6    17G65  2018-07-11  macOS High Sierra
3    041-69971    10.14.5  18F2058  2019-07-09  macOS Mojave
4    041-47723    10.14.4  18E2034  2019-03-25  macOS Mojave
5    041-59913    10.14.5   18F132  2019-05-13  macOS Mojave
6    041-73257    10.14.5  18F2059  2019-07-31  macOS Mojave
7    091-95774    10.13.6  17G2208  2018-07-30  macOS High Sierra
8    041-88929    10.14.6    18G84  2019-07-22  macOS Mojave
Also, don't forget that you have to run this script on the 2018 MBP, or on a virtual machine, in order to make the 17G2208 installer.
weird, when i download it and make a bootable, it quits and defaults to a Mojave installer.
 

chrfr

macrumors G3
Jul 11, 2009
8,584
2,767
weird, when i download it and make a bootable, it quits and defaults to a Mojave installer.
That's not the behavior I see when I try it, so I can't begin to guess what you have going on. With that said, I believe I've heard there are problems when trying to downgrade from Mojave to High Sierra, and the fix in that case is to downgrade to 10.14 (not a later revision) and then you can downgrade from there to 10.13.6.
 
  • Like
Reactions: Ploki

yukari

macrumors 6502
Jun 29, 2010
473
209
So I followed this to get 17G2208 to show up (combination of the original post by TriBruin and a modified command by chrfr):

(1) cd ~/Downloads (or other folder where "installinstallmacos.py" is located)
(2) chmod +x ./installinstallmacos.py
(3) sudo ./installinstallmacos.py --catalogurl https://swscan.apple.com/content/catalogs/others/index-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog
(4) Type your user password (assuming you are an Administrator)

Mine showed up as option #1