How to display COMPANY NAME in contact list instead of its representative?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by luisadastwin, Jan 15, 2015.

  1. luisadastwin macrumors regular

    luisadastwin

    Joined:
    Oct 9, 2010
    Location:
    Antas - Porto - Portugal - Europe
    #1
    Hi everyone!

    Let me start by saying that I do not have a Mac and I must do everything in iOS! (because this issue can be solved in Mac by activating a check box called "this is a company" or something like that).

    Before iOS7 its used to be perfectly possible to display the company name in the contact list instead of its representative: if we wanted to insert a Company and also its representative's first and last name, but display the COMPANY NAME in the contacts list, the M.O. was:

    1. Insert COMPANY NAME, in the "Company" field. And ONLY this field.
    2. Insert Telephone number
    3. SAVE contact
    4. Edit Contact AGAIN and, only now, insert FIRST and LAST name of the Company's representative in the "First Name" and "Last Name" fields.
    5. SAVE again

    So, this way, when you saved a new contact ONLY with a company name, iOS would know that it was a company contact and would display the company name in the contact list (even if you added later a representative's first and last name).

    On the other hand, if you create a new contact, filling up the first and last name fields, the iOS would know it is a person's contact, always displaying the First and Last name in the contacts (even if you add later a company name).

    But after iOS7, this is not possible now.. It's very irritating...

    How can I make this work in iOS now?

    I have my contacts synced with Google, and also in Google we can't define that..

    Is there an App for that?

    Thanks.
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    Put the representative name in a different field like under Notes for example and you will be able to display contact by company name.
     
  3. luisadastwin thread starter macrumors regular

    luisadastwin

    Joined:
    Oct 9, 2010
    Location:
    Antas - Porto - Portugal - Europe
    #3
    Thank you, it is a workaround... But I have a sort of OCD / issue about that... (I don't know if it is a Engineer thing) :confused:

    That is, I like to have my contact database very well organized... It makes no sense (to me) to have a First and Last persons name in a "notes" field... I will later synchronize contacts with other applications and the first and last name are not going to be there...

    If MAC can do that (mark contact as a "Company" type), there must be other applications to do that, right?





     
  4. luisadastwin thread starter macrumors regular

    luisadastwin

    Joined:
    Oct 9, 2010
    Location:
    Antas - Porto - Portugal - Europe
    #4
    iOS 8 is out and still no solution for this...? Is there any PC software to solve this?
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    Sounds like before iOS 7 there was a bug of some sort that allowed you to do it even though it wasn't really meant to work like that, and it was then fixed.

    Perhaps you can save the company name under nickname and then use the options at Settings > Mail, Contacts, Calendars > Short Name to prefer nicknames, for example.
     
  6. luisadastwin thread starter macrumors regular

    luisadastwin

    Joined:
    Oct 9, 2010
    Location:
    Antas - Porto - Portugal - Europe
    #6
    OMG... :rolleyes:

    That excellent FEATURE was considered a BUG?!?!? LOL that's unbelievable....

    Yes, I understand the workaround, but I really like to have information well organized since I have THOUSANDS of contacts... The Company name goes to the Company Field. The First and Last name goes to the first and last name fields ;);)

    I know that in the MAC you can set a contact as a "Business" or "Company", kind of: "this contact is a company" or something like that. I just wish I could do something similar even with a third party app.. :(

    Thanks again





     

Share This Page